User account creation filtered due to spam.

Bug 7151 - [sparc] ICE when compiling for UltraSPARC
Summary: [sparc] ICE when compiling for UltraSPARC
Status: RESOLVED DUPLICATE of bug 8281
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 3.1
: P3 normal
Target Milestone: ---
Assignee: Eric Botcazou
URL:
Keywords: ice-on-valid-code
: 6986 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-06-28 02:16 UTC by gawrilow
Modified: 2003-06-12 00:15 UTC (History)
4 users (show)

See Also:
Host: sparc-sun-solaris2.8
Target: sparc-sun-solaris2.8
Build: sparc-sun-solaris2.8
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gawrilow 2002-06-28 02:16:00 UTC
I have tried to compile Mozilla 1.0 from the sources for the
UltraSPARC platform. It got stuck at the following file:

gcc -o e_pow.o -c -DOSTYPE=\"SunOS5\" -DOSARCH=\"SunOS\" -DOJI   -I../../../dist/include/js -I../../../dist/include -I/net/jabba.opt/combi/gawrilow/mozilla/dist/include/nspr     -I/usr/lib/include -I/usr/openwin/include   -fPIC -I/usr/openwin/include -pedantic -Wno-long-long -mcpu=ultrasparc -fshort-wchar -pthreads  -DNDEBUG -DTRIMMED -O3 -D_IEEE_LIBM  -I/usr/openwin/include -include ../../../config-defs.h -DMOZILLA_CLIENT -Wp,-MD,.deps/e_pow.pp e_pow.c

e_pow.c: In function `__ieee754_pow':
e_pow.c:376: insn does not satisfy its constraints:
(insn 1875 777 1878 (set (reg:DI 34 %f2)
        (reg/v:DI 64 %f32 [112])) 58 {*movdi_insn_sp32_v9} (nil)
    (nil))
e_pow.c:376: Internal compiler error in reload_cse_simplify_operands, at reload1.c:8368

Release:
3.1

Environment:
System: SunOS jabba 5.8 Generic_108528-13 sun4u sparc SUNW,UltraAX-MP
Architecture: sun4

	
host: sparc-sun-solaris2.8
build: sparc-sun-solaris2.8
target: sparc-sun-solaris2.8
configured with: /homes/combi/gawrilow/tmp/gcc-3.1/configure --prefix=/usr/site-local/experimental --with-local-prefix=/usr/site-local --with-gxx-include-dir=/usr/site-local/share/include/g++ --enable-shared --enable-libgcj --enable-languages=c++,java --with-cpu=ultrasparc

How-To-Repeat:
# 1 "e_pow.c"
# 1 "<built-in>"
# 1 "<command line>"
# 1 "../../../config-defs.h" 1
/* List of defines generated by configure. Included with preprocessor flag,
 * -include, to avoid long list of -D defines on the compile command-line.
 * Do not edit.
 */
# 2 "<command line>" 2
# 1 "e_pow.c"
/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 4 -*-
 *
 * The contents of this file are subject to the Netscape Public
 * License Version 1.1 (the "License"); you may not use this file
 * except in compliance with the License. You may obtain a copy of
 * the License at http://www.mozilla.org/NPL/
 *
 * Software distributed under the License is distributed on an "AS
 * IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
 * implied. See the License for the specific language governing
 * rights and limitations under the License.
 *
 * The Original Code is Mozilla Communicator client code, released
 * March 31, 1998.
 *
 * The Initial Developer of the Original Code is Sun Microsystems,
 * Inc.  Portions created by Netscape are
 * Copyright (C) 1998 Netscape Communications Corporation. All
 * Rights Reserved.
 *
 * Contributor(s): 
 *
 * Alternatively, the contents of this file may be used under the
 * terms of the GNU Public License (the "GPL"), in which case the
 * provisions of the GPL are applicable instead of those above.
 * If you wish to allow use of your version of this file only
 * under the terms of the GPL and not to allow others to use your
 * version of this file under the NPL, indicate your decision by
 * deleting the provisions above and replace them with the notice
 * and other provisions required by the GPL.  If you do not delete
 * the provisions above, a recipient may use your version of this
 * file under either the NPL or the GPL.
 */

/* @(#)e_pow.c 1.3 95/01/18 */
/*
 * ====================================================
 * Copyright (C) 1993 by Sun Microsystems, Inc. All rights reserved.
 *
 * Developed at SunSoft, a Sun Microsystems, Inc. business.
 * Permission to use, copy, modify, and distribute this
 * software is freely granted, provided that this notice 
 * is preserved.
 * ====================================================
 */

/* __ieee754_pow(x,y) return x**y
 *
 *		      n
 * Method:  Let x =  2   * (1+f)
 *	1. Compute and return log2(x) in two pieces:
 *		log2(x) = w1 + w2,
 *	   where w1 has 53-24 = 29 bit trailing zeros.
 *	2. Perform y*log2(x) = n+y' by simulating muti-precision 
 *	   arithmetic, where |y'|<=0.5.
 *	3. Return x**y = 2**n*exp(y'*log2)
 *
 * Special cases:
 *	1.  (anything) ** 0  is 1
 *	2.  (anything) ** 1  is itself
 *	3.  (anything) ** NAN is NAN
 *	4.  NAN ** (anything except 0) is NAN
 *	5.  +-(|x| > 1) **  +INF is +INF
 *	6.  +-(|x| > 1) **  -INF is +0
 *	7.  +-(|x| < 1) **  +INF is +0
 *	8.  +-(|x| < 1) **  -INF is +INF
 *	9.  +-1         ** +-INF is NAN
 *	10. +0 ** (+anything except 0, NAN)               is +0
 *	11. -0 ** (+anything except 0, NAN, odd integer)  is +0
 *	12. +0 ** (-anything except 0, NAN)               is +INF
 *	13. -0 ** (-anything except 0, NAN, odd integer)  is +INF
 *	14. -0 ** (odd integer) = -( +0 ** (odd integer) )
 *	15. +INF ** (+anything except 0,NAN) is +INF
 *	16. +INF ** (-anything except 0,NAN) is +0
 *	17. -INF ** (anything)  = -0 ** (-anything)
 *	18. (-anything) ** (integer) is (-1)**(integer)*(+anything**integer)
 *	19. (-anything except 0 and inf) ** (non-integer) is NAN
 *
 * Accuracy:
 *	pow(x,y) returns x**y nearly rounded. In particular
 *			pow(integer,integer)
 *	always returns the correct integer provided it is 
 *	representable.
 *
 * Constants :
 * The hexadecimal values are the intended ones for the following 
 * constants. The decimal values may be used, provided that the 
 * compiler will convert from decimal to binary accurately enough 
 * to produce the hexadecimal values shown.
 */

# 1 "fdlibm.h" 1
/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 4 -*-
 *
 * The contents of this file are subject to the Netscape Public
 * License Version 1.1 (the "License"); you may not use this file
 * except in compliance with the License. You may obtain a copy of
 * the License at http://www.mozilla.org/NPL/
 *
 * Software distributed under the License is distributed on an "AS
 * IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
 * implied. See the License for the specific language governing
 * rights and limitations under the License.
 *
 * The Original Code is Mozilla Communicator client code, released
 * March 31, 1998.
 *
 * The Initial Developer of the Original Code is Sun Microsystems,
 * Inc.  Portions created by Netscape are
 * Copyright (C) 1998 Netscape Communications Corporation. All
 * Rights Reserved.
 *
 * Contributor(s): 
 *
 * Alternatively, the contents of this file may be used under the
 * terms of the GNU Public License (the "GPL"), in which case the
 * provisions of the GPL are applicable instead of those above.
 * If you wish to allow use of your version of this file only
 * under the terms of the GPL and not to allow others to use your
 * version of this file under the NPL, indicate your decision by
 * deleting the provisions above and replace them with the notice
 * and other provisions required by the GPL.  If you do not delete
 * the provisions above, a recipient may use your version of this
 * file under either the NPL or the GPL.
 */

/* @(#)fdlibm.h 1.5 95/01/18 */
/*
 * ====================================================
 * Copyright (C) 1993 by Sun Microsystems, Inc. All rights reserved.
 *
 * Developed at SunSoft, a Sun Microsystems, Inc. business.
 * Permission to use, copy, modify, and distribute this
 * software is freely granted, provided that this notice 
 * is preserved.
 * ====================================================
 */

/* Modified defines start here.. */
# 63 "fdlibm.h"
/* End here. The rest is the standard file. */
# 72 "fdlibm.h"
typedef union {



    struct { int hi, lo; } ints;

    double d;
} fd_twoints;
# 91 "fdlibm.h"
/*
 * ANSI/POSIX
 */

extern int signgam;



enum fdversion {fdlibm_ieee = -1, fdlibm_svid, fdlibm_xopen, fdlibm_posix};




/* if global variable _LIB_VERSION is not desirable, one may 
 * change the following to be a constant by: 
 *	#define _LIB_VERSION_TYPE const enum version
 * In that case, after one initializes the value _LIB_VERSION (see
 * s_lib_version.c) during compile time, it cannot be modified
 * in the middle of a program
 */
extern enum fdversion _fdlib_version;






struct exception {
        int type;
        char *name;
        double arg1;
        double arg2;
        double retval;
};



/* 
 * set X_TLOSS = pi*2**52, which is possibly defined in <values.h>
 * (one may replace the following line by "#include <values.h>")
 */
# 142 "fdlibm.h"
/*
 * ANSI/POSIX
 */

extern double fd_acos (double);
extern double fd_asin (double);
extern double fd_atan (double);
extern double fd_atan2 (double, double);
extern double fd_cos (double);
extern double fd_sin (double);
extern double fd_tan (double);

extern double fd_cosh (double);
extern double fd_sinh (double);
extern double fd_tanh (double);

extern double fd_exp (double);
extern double fd_frexp (double, int *);
extern double fd_ldexp (double, int);
extern double fd_log (double);
extern double fd_log10 (double);
extern double fd_modf (double, double *);

extern double fd_pow (double, double);
extern double fd_sqrt (double);

extern double fd_ceil (double);
extern double fd_fabs (double);
extern double fd_floor (double);
extern double fd_fmod (double, double);

extern double fd_erf (double);
extern double fd_erfc (double);
extern double fd_gamma (double);
extern double fd_hypot (double, double);
extern int fd_isnan (double);
extern int fd_finite (double);
extern double fd_j0 (double);
extern double fd_j1 (double);
extern double fd_jn (int, double);
extern double fd_lgamma (double);
extern double fd_y0 (double);
extern double fd_y1 (double);
extern double fd_yn (int, double);

extern double fd_acosh (double);
extern double fd_asinh (double);
extern double fd_atanh (double);
extern double fd_cbrt (double);
extern double fd_logb (double);
extern double fd_nextafter (double, double);
extern double fd_remainder (double, double);



extern double fd_scalb (double, double);


extern int fd_matherr (struct exception *);

/*
 * IEEE Test Vector
 */
extern double significand (double);

/*
 * Functions callable from C, intended to support IEEE arithmetic.
 */
extern double fd_copysign (double, double);
extern int fd_ilogb (double);
extern double fd_rint (double);
extern double fd_scalbn (double, int);

/*
 * BSD math library entry points
 */
extern double fd_expm1 (double);
extern double fd_log1p (double);

/*
 * Reentrant version of gamma & lgamma; passes signgam back by reference
 * as the second argument; user must allocate space for signgam.
 */

extern double gamma_r (double, int *);
extern double lgamma_r (double, int *);


/* ieee style elementary functions */
extern double __ieee754_sqrt (double);
extern double __ieee754_acos (double);
extern double __ieee754_acosh (double);
extern double __ieee754_log (double);
extern double __ieee754_atanh (double);
extern double __ieee754_asin (double);
extern double __ieee754_atan2 (double,double);
extern double __ieee754_exp (double);
extern double __ieee754_cosh (double);
extern double __ieee754_fmod (double,double);
extern double __ieee754_pow (double,double);
extern double __ieee754_lgamma_r (double,int *);
extern double __ieee754_gamma_r (double,int *);
extern double __ieee754_lgamma (double);
extern double __ieee754_gamma (double);
extern double __ieee754_log10 (double);
extern double __ieee754_sinh (double);
extern double __ieee754_hypot (double,double);
extern double __ieee754_j0 (double);
extern double __ieee754_j1 (double);
extern double __ieee754_y0 (double);
extern double __ieee754_y1 (double);
extern double __ieee754_jn (int,double);
extern double __ieee754_yn (int,double);
extern double __ieee754_remainder (double,double);
extern int __ieee754_rem_pio2 (double,double*);



extern double __ieee754_scalb (double,double);


/* fdlibm kernel function */
extern double __kernel_standard (double,double,int,int*);
extern double __kernel_sin (double,double,int);
extern double __kernel_cos (double,double);
extern double __kernel_tan (double,double,int);
extern int __kernel_rem_pio2 (double*,double*,int,int,int,const int*);
# 93 "e_pow.c" 2


static const double



bp[] = {1.0, 1.5,},
dp_h[] = { 0.0, 5.84962487220764160156e-01,}, /* 0x3FE2B803, 0x40000000 */
dp_l[] = { 0.0, 1.35003920212974897128e-08,}, /* 0x3E4CFDEB, 0x43CFD006 */
zero = 0.0,
one = 1.0,
two = 2.0,
two53 = 9007199254740992.0, /* 0x43400000, 0x00000000 */
really_big = 1.0e300,
tiny = 1.0e-300,
        /* poly coefs for (3/2)*(log(x)-2s-2/3*s**3 */
L1 = 5.99999999999994648725e-01, /* 0x3FE33333, 0x33333303 */
L2 = 4.28571428578550184252e-01, /* 0x3FDB6DB6, 0xDB6FABFF */
L3 = 3.33333329818377432918e-01, /* 0x3FD55555, 0x518F264D */
L4 = 2.72728123808534006489e-01, /* 0x3FD17460, 0xA91D4101 */
L5 = 2.30660745775561754067e-01, /* 0x3FCD864A, 0x93C9DB65 */
L6 = 2.06975017800338417784e-01, /* 0x3FCA7E28, 0x4A454EEF */
P1 = 1.66666666666666019037e-01, /* 0x3FC55555, 0x5555553E */
P2 = -2.77777777770155933842e-03, /* 0xBF66C16C, 0x16BEBD93 */
P3 = 6.61375632143793436117e-05, /* 0x3F11566A, 0xAF25DE2C */
P4 = -1.65339022054652515390e-06, /* 0xBEBBBD41, 0xC5D26BF1 */
P5 = 4.13813679705723846039e-08, /* 0x3E663769, 0x72BEA4D0 */
lg2 = 6.93147180559945286227e-01, /* 0x3FE62E42, 0xFEFA39EF */
lg2_h = 6.93147182464599609375e-01, /* 0x3FE62E43, 0x00000000 */
lg2_l = -1.90465429995776804525e-09, /* 0xBE205C61, 0x0CA86C39 */
ovt = 8.0085662595372944372e-0017, /* -(1024-log2(ovfl+.5ulp)) */
cp = 9.61796693925975554329e-01, /* 0x3FEEC709, 0xDC3A03FD =2/(3ln2) */
cp_h = 9.61796700954437255859e-01, /* 0x3FEEC709, 0xE0000000 =(float)cp */
cp_l = -7.02846165095275826516e-09, /* 0xBE3E2FE0, 0x145B01F5 =tail of cp_h*/
ivln2 = 1.44269504088896338700e+00, /* 0x3FF71547, 0x652B82FE =1/ln2 */
ivln2_h = 1.44269502162933349609e+00, /* 0x3FF71547, 0x60000000 =24b 1/ln2*/
ivln2_l = 1.92596299112661746887e-08; /* 0x3E54AE0B, 0xF85DDF44 =1/ln2 tail*/


        double __ieee754_pow(double x, double y)




{
        fd_twoints ux, uy, uz;
        double y1,t1,p_h,t,z,ax;
        double z_h,z_l,p_l;
        double t2,r,s,u,v,w;
        int i,j,k,yisint,n;
        int hx,hy,ix,iy;
        unsigned lx,ly;

        ux.d = x; uy.d = y;
        hx = ux.ints.hi; lx = ux.ints.lo;
        hy = uy.ints.hi; ly = uy.ints.lo;
        ix = hx&0x7fffffff; iy = hy&0x7fffffff;

    /* y==zero: x**0 = 1 */
        if((iy|ly)==0) return one;

    /* +-NaN return x+y */
        if(ix > 0x7ff00000 || ((ix==0x7ff00000)&&(lx!=0)) ||
           iy > 0x7ff00000 || ((iy==0x7ff00000)&&(ly!=0)))
                return x+y;

    /* determine if y is an odd int when x < 0
     * yisint = 0	... y is not an integer
     * yisint = 1	... y is an odd int
     * yisint = 2	... y is an even int
     */
        yisint = 0;
        if(hx<0) {
            if(iy>=0x43400000) yisint = 2; /* even integer y */
            else if(iy>=0x3ff00000) {
                k = (iy>>20)-0x3ff; /* exponent */
                if(k>20) {
                    j = ly>>(52-k);
                    if((j<<(52-k))==(int)ly) yisint = 2-(j&1);
                } else if(ly==0) {
                    j = iy>>(20-k);
                    if((j<<(20-k))==iy) yisint = 2-(j&1);
                }
            }
        }

    /* special value of y */
        if(ly==0) {
            if (iy==0x7ff00000) { /* y is +-inf */
                if(((ix-0x3ff00000)|lx)==0)




                    return y - y; /* inf**+-1 is NaN */

                else if (ix >= 0x3ff00000)/* (|x|>1)**+-inf = inf,0 */
                    return (hy>=0)? y: zero;
                else /* (|x|<1)**-,+inf = inf,0 */
                    return (hy<0)?-y: zero;
            }
            if(iy==0x3ff00000) { /* y is  +-1 */
                if(hy<0) return one/x; else return x;
            }
            if(hy==0x40000000) return x*x; /* y is  2 */
            if(hy==0x3fe00000) { /* y is  0.5 */
                if(hx>=0) /* x >= +0 */
                return fd_sqrt(x);
            }
        }

        ax = fd_fabs(x);
    /* special value of x */
        if(lx==0) {
            if(ix==0x7ff00000||ix==0||ix==0x3ff00000){
                z = ax; /*x is +-0,+-inf,+-1*/
                if(hy<0) z = one/z; /* z = (1/|x|) */
                if(hx<0) {
                    if(((ix-0x3ff00000)|yisint)==0) {
                        z = (z-z)/(z-z); /* (-1)**non-int is NaN */
                    } else if(yisint==1) {





                        z = -z; /* (x<0)**odd = -(|x|**odd) */

                        }
                }
                return z;
            }
        }

    /* (x<0)**(non-int) is NaN */
        if((((hx>>31)+1)|yisint)==0) return (x-x)/(x-x);

    /* |y| is really_big */
        if(iy>0x41e00000) { /* if |y| > 2**31 */
            if(iy>0x43f00000){ /* if |y| > 2**64, must o/uflow */
                if(ix<=0x3fefffff) return (hy<0)? really_big*really_big:tiny*tiny;
                if(ix>=0x3ff00000) return (hy>0)? really_big*really_big:tiny*tiny;
            }
        /* over/underflow if x is not close to one */
            if(ix<0x3fefffff) return (hy<0)? really_big*really_big:tiny*tiny;
            if(ix>0x3ff00000) return (hy>0)? really_big*really_big:tiny*tiny;
        /* now |1-x| is tiny <= 2**-20, suffice to compute 
	   log(x) by x-x^2/2+x^3/3-x^4/4 */
            t = x-1; /* t has 20 trailing zeros */
            w = (t*t)*(0.5-t*(0.3333333333333333333333-t*0.25));
            u = ivln2_h*t; /* ivln2_h has 21 sig. bits */
            v = t*ivln2_l-w*ivln2;
            t1 = u+v;
            uz.d = t1;
            uz.ints.lo = 0;
            t1 = uz.d;
            t2 = v-(t1-u);
        } else {
            double s_h,t_h;
            double s2,s_l,t_l;
            n = 0;
        /* take care subnormal number */
            if(ix<0x00100000)
                {ax *= two53; n -= 53; uz.d = ax; ix = uz.ints.hi; }
            n += ((ix)>>20)-0x3ff;
            j = ix&0x000fffff;
        /* determine interval */
            ix = j|0x3ff00000; /* normalize ix */
            if(j<=0x3988E) k=0; /* |x|<sqrt(3/2) */
            else if(j<0xBB67A) k=1; /* |x|<sqrt(3)   */
            else {k=0;n+=1;ix -= 0x00100000;}
            uz.d = ax;
            uz.ints.hi = ix;
            ax = uz.d;

        /* compute s = s_h+s_l = (x-1)/(x+1) or (x-1.5)/(x+1.5) */
            u = ax-bp[k]; /* bp[0]=1.0, bp[1]=1.5 */
            v = one/(ax+bp[k]);
            s = u*v;
            s_h = s;
            uz.d = s_h;
            uz.ints.lo = 0;
            s_h = uz.d;
        /* t_h=ax+bp[k] High */
            t_h = zero;
            uz.d = t_h;
            uz.ints.hi=((ix>>1)|0x20000000)+0x00080000+(k<<18);
            t_h = uz.d;
            t_l = ax - (t_h-bp[k]);
            s_l = v*((u-s_h*t_h)-s_h*t_l);
        /* compute log(ax) */
            s2 = s*s;
            r = s2*s2*(L1+s2*(L2+s2*(L3+s2*(L4+s2*(L5+s2*L6)))));
            r += s_l*(s_h+s);
            s2 = s_h*s_h;
            t_h = 3.0+s2+r;
            uz.d = t_h;
            uz.ints.lo = 0;
            t_h = uz.d;
            t_l = r-((t_h-3.0)-s2);
        /* u+v = s*(1+...) */
            u = s_h*t_h;
            v = s_l*t_h+t_l*s;
        /* 2/(3log2)*(s+...) */
            p_h = u+v;
            uz.d = p_h;
            uz.ints.lo = 0;
            p_h = uz.d;
            p_l = v-(p_h-u);
            z_h = cp_h*p_h; /* cp_h+cp_l = 2/(3*log2) */
            z_l = cp_l*p_h+p_l*cp+dp_l[k];
        /* log2(ax) = (s+..)*2/(3*log2) = n + dp_h + z_h + z_l */
            t = (double)n;
            t1 = (((z_h+z_l)+dp_h[k])+t);
            uz.d = t1;
            uz.ints.lo = 0;
            t1 = uz.d;
            t2 = z_l-(((t1-t)-dp_h[k])-z_h);
        }

        s = one; /* s (sign of result -ve**odd) = -1 else = 1 */
        if((((hx>>31)+1)|(yisint-1))==0) s = -one;/* (-ve)**(odd int) */

    /* split up y into y1+y2 and compute (y1+y2)*(t1+t2) */
        y1 = y;
        uy.d = y1;
        uy.ints.lo = 0;
        y1 = uy.d;
        p_l = (y-y1)*t1+y*t2;
        p_h = y1*t1;
        z = p_l+p_h;
        uz.d = z;
        j = uz.ints.hi;
        i = uz.ints.lo;

        if (j>=0x40900000) { /* z >= 1024 */
            if(((j-0x40900000)|i)!=0) /* if z > 1024 */
                return s*really_big*really_big; /* overflow */
            else {
                if(p_l+ovt>z-p_h) return s*really_big*really_big; /* overflow */
            }
        } else if((j&0x7fffffff)>=0x4090cc00 ) { /* z <= -1075 */
            if(((j-0xc090cc00)|i)!=0) /* z < -1075 */
                return s*tiny*tiny; /* underflow */
            else {
                if(p_l<=z-p_h) return s*tiny*tiny; /* underflow */
            }
        }
    /*
     * compute 2**(p_h+p_l)
     */
        i = j&0x7fffffff;
        k = (i>>20)-0x3ff;
        n = 0;
        if(i>0x3fe00000) { /* if |z| > 0.5, set n = [z+0.5] */
            n = j+(0x00100000>>(k+1));
            k = ((n&0x7fffffff)>>20)-0x3ff; /* new k for n */
            t = zero;
            uz.d = t;
            uz.ints.hi = (n&~(0x000fffff>>k));
            t = uz.d;
            n = ((n&0x000fffff)|0x00100000)>>(20-k);
            if(j<0) n = -n;
            p_h -= t;
        }
        t = p_l+p_h;
        uz.d = t;
        uz.ints.lo = 0;
        t = uz.d;
        u = t*lg2_h;
        v = (p_l-(t-p_h))*lg2+t*lg2_l;
        z = u+v;
        w = v-(z-u);
        t = z*z;
        t1 = z - t*(P1+t*(P2+t*(P3+t*(P4+t*P5))));
        r = (z*t1)/(t1-two)-(w+z*w);
        z = one-(r-z);
        uz.d = z;
        j = uz.ints.hi;
        j += (n<<20);
        if((j>>20)<=0) z = fd_scalbn(z,n); /* subnormal output */
        else { uz.d = z; uz.ints.hi += (n<<20); z = uz.d; }
        return s*z;
}
Comment 1 gawrilow 2002-06-28 02:16:00 UTC
Fix:
Compilation with -mcpu=supersparc succeeded.
Comment 2 David S. Miller 2002-10-01 20:54:29 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Fixed in mainline and 3.2 branch, fix will appear in
    the upcoming 3.2.1 release in a few weeks.
Comment 3 Uroš Bizjak 2003-02-06 14:05:06 UTC
From: Uros Bizjak <uros@kss-loka.si>
To: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org, nobody@gcc.gnu.org,
	gcc-prs@gcc.gnu.org, gawrilow@math.TU-Berlin.DE
Cc:  
Subject: Re: middle-end/7151: ICE when compiling for UltraSPARC
Date: Thu, 06 Feb 2003 14:05:06 +0100

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=7151
 
    This bug is not fixed in 3.2.2 release. PR7151 and PR8281 describe 
 the same bug (PR8281 has a nice testcase included, PR8654 has another 
 testcase for the same problem) and with gcc 3.2.2 I got segmentation 
 fault instead of ICE in line 43:
 
  > gcc -O2 -c -fPIC -mcpu=ultrasparc 8281.c
 8281.c: In function `__ieee754_pow':
 8281.c:43: internal error: Segmentation Fault
 Please submit a full bug report,
 with preprocessed source if appropriate.
 See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions
 
  > gcc -v
 Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.2.2/specs
 Configured with: ../gcc-3.2.2/configure --with-gnu-ld
 Thread model: posix
 gcc version 3.2.2
 
 	Uros.
 
Comment 4 Wolfgang Bangerth 2003-02-06 15:10:56 UTC
State-Changed-From-To: closed->open
State-Changed-Why: Apparently not fixed. Should be re-evaluated with someone
    with an ultrasparc
Comment 5 Eric Botcazou 2003-03-22 14:26:47 UTC
*** This bug has been marked as a duplicate of 8281 ***