User account creation filtered due to spam.

Bug 7034 - ICE on -march=athlon for CLAPACK code
Summary: ICE on -march=athlon for CLAPACK code
Status: RESOLVED DUPLICATE of bug 7124
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 3.1
: P3 normal
Target Milestone: ---
Assignee: Richard Henderson
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2002-06-14 16:06 UTC by perrin
Modified: 2003-06-12 00:15 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
athlonbug.tar (3.61 KB, application/octet-stream)
2003-05-21 15:17 UTC, perrin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description perrin 2002-06-14 16:06:00 UTC
ICE one some files when compiling http://www.netlib.org/clapack with
-O2 -march=athlon

[perrin@wave GCC31_BUG]$ /home/perrin/gcc-3.1_INSTALL/bin/gcc -c -O2 -march=athlon clacrt.c 
clacrt.c: In function `clacrt_':
clacrt.c:136: Internal compiler error in ix86_secondary_memory_needed, at config/i386/i386.c:12251
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

Release:
gcc 3.1

Environment:
Athlon / Linux

How-To-Repeat:
gcc -c -O2 -march=athlon clacrt.c
Comment 1 Richard Henderson 2002-10-02 13:40:43 UTC
*** This bug has been marked as a duplicate of 7124 ***