Bug 6993 - info page outdated about Input files
Summary: info page outdated about Input files
Status: NEW
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 3.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL: http://gcc.gnu.org/ml/java-patches/20...
Keywords: documentation
Depends on: 30515
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-11 07:46 UTC by daniel.bonniot
Modified: 2009-02-23 19:23 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-09-30 13:36:27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.bonniot 2002-06-11 07:46:02 UTC
The manpage says: 
"
 (If more
 than one input file is specified, all must currently be
 ".java" files, though we hope to fix this.)
"

I think this limitation has been removed.
Also, shouldn't .o files appear in the list of supported input files?

Release:
3.1
Comment 1 Dara Hazeghi 2003-05-27 06:14:58 UTC
Hello,

I can confirm that this behavior is still present in gcc 3.3 branch and mainline (20030525) 
(leastaways, the docs read the same).

Dara
Comment 2 Andrew Pinski 2003-05-27 14:58:43 UTC
See Dara's comment.
Comment 3 Andrew Pinski 2003-08-03 18:04:29 UTC
The limitation was removed a long time ago.