Bug 69527 - Rubbish code within 'switch' doesn't trigger warning
Summary: Rubbish code within 'switch' doesn't trigger warning
Status: RESOLVED DUPLICATE of bug 51896
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.8.4
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: diagnostic
Depends on:
Blocks:
 
Reported: 2016-01-28 09:24 UTC by filip pancik
Modified: 2016-01-28 09:35 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
-save-temps output (3.01 KB, text/plain)
2016-01-28 09:24 UTC, filip pancik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description filip pancik 2016-01-28 09:24:50 UTC
Created attachment 37504 [details]
-save-temps output

the exact version of GCC:
4.8.4

the system type:
Linux pi64 3.16.0-56-generic #75~14.04.1-Ubuntu SMP Wed Dec 2 11:27:25 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

the options given when GCC was configured/built:
-Wall -Wextra

the complete command line that triggers the bug:
None

the compiler output (error messages, warnings, etc.):
None

the preprocessed file (*.i*) that triggers the bug, generated by adding -save-temps to the complete compilation command:
attached
Comment 1 Marek Polacek 2016-01-28 09:35:36 UTC
Dup.

*** This bug has been marked as a duplicate of bug 51896 ***