Bug 69227 - FAIL: gcc.dg/torture/builtin-integral-1.c -O1 (test for excess errors)
Summary: FAIL: gcc.dg/torture/builtin-integral-1.c -O1 (test for excess errors)
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 6.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-11 13:53 UTC by Andre Vieira
Modified: 2016-01-28 13:50 UTC (History)
0 users

See Also:
Host:
Target: arm-none-eabi
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Vieira 2016-01-11 13:53:26 UTC
Commit r232191 causes the following fail on arm-none-eabi target:

FAIL: gcc.dg/torture/builtin-integral-1.c -O1 (test for excess errors)

As it no longer folds away __builtin_ceill for __builtin_fabsf. This is because Gerald's patch checks for 'targetm.libc_has_function (function_c99_misc)' for a transformation used here and, for arm-none-eabi, TARGET_LIBC_HAS_FUNCTION is defined as 'no_c99_libc_has_function', which always returns false.

The question now is whether we should support function_c99_misc with 'arm-none-eabi', which comes with newlib. I believe newlib does not claim to fully support C99.
Comment 1 ktkachov 2016-01-11 13:57:09 UTC
Relevant thread on gcc-patches:
https://gcc.gnu.org/ml/gcc-patches/2016-01/msg00586.html
Comment 2 Andre Vieira 2016-01-11 14:31:53 UTC
I have decided to email the newlib mailinglist to figure out which function classes we should and should not support for 'arm-none-eabi'.

See https://sourceware.org/ml/newlib/2016/msg00009.html
Comment 3 Andre Vieira 2016-01-28 13:50:44 UTC
Test was changed to require C99 runtime in r232487.