User account creation filtered due to spam.

Bug 6744 - Generates ASM containing reference to pseudo register z
Summary: Generates ASM containing reference to pseudo register z
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 2.95.3
: P3 normal
Target Milestone: ---
Assignee: Stephane Carrez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-05-20 09:46 UTC by imajeffs
Modified: 2003-07-25 17:33 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
eeprom.i.Z (4.49 KB, application/x-compress )
2003-05-21 15:17 UTC, imajeffs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description imajeffs 2002-05-20 09:46:01 UTC
When my file is compiled by:
m6811-elf-gcc -m68hc12 -mshort -Wall -Os -c eeprom.i

It places the ASM:
==============
        ldx     #_io_ports+243
; Begin inline assembler code
#APP
        bset 0,z,#22
; End of inline assembler code
#NO_APP
==============

Because of the 'z' which should have been 'x',
my code will not even compile.

I beleive it is not generating the error without optimizations (when I removed -Os).

Release:
gcc version 2.95.3 20010315 (release)+m68hc1x-20010922

Environment:
Red Hat Linux 6.2

How-To-Repeat:
try compiling with:
m6811-elf-gcc -m68hc12 -mshort -Wall -Os -c eeprom.i
Comment 1 Stephane Carrez 2002-05-21 10:46:05 UTC
Responsible-Changed-From-To: unassigned->ciceron
Responsible-Changed-Why: Concerns HC11 port
Comment 2 Stephane Carrez 2002-07-22 14:11:20 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Fixed with http://gcc.gnu.org/ml/gcc-patches/2002-07/msg01241.html
    (committed on mainline, ie 3.2)