Bug 66901 - Segmentation fault in compiler instead of error message for ill-formed program with namespace alias and qualified definition
Summary: Segmentation fault in compiler instead of error message for ill-formed progra...
Status: RESOLVED DUPLICATE of bug 66879
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: unknown
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-invalid-code
Depends on:
Blocks:
 
Reported: 2015-07-17 01:16 UTC by Anders Granlund
Modified: 2015-07-27 00:57 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail: 6.0
Last reconfirmed:


Attachments
The program prog.cc used in the command line (83 bytes, text/plain)
2015-07-17 01:16 UTC, Anders Granlund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Granlund 2015-07-17 01:16:18 UTC
Created attachment 35999 [details]
The program prog.cc used in the command line

Compile the attached program prog.cc with the following command line:

gcc prog.cc

This results in a segmentation fault instead of an error message:

gcc: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.

Since the program is ill-formed and diagnostics is required, the expected behaviour is to get an error message instead of a segmentation fault.

Output for gcc -v:

Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.8.2-19ubuntu1' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
Comment 1 Mikhail Maltsev 2015-07-17 09:04:00 UTC
Reproduces on trunk. Possibly a dup of PR66878 (also caused by infinite recursion in push_inner_scope_r).
Comment 2 Anders Granlund 2015-07-27 00:57:55 UTC
This is consequence of 66901. I'm moving it there.

*** This bug has been marked as a duplicate of bug 66879 ***