Bug 6606 - [SH]sh-linux compiler fails to build libgcc
Summary: [SH]sh-linux compiler fails to build libgcc
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: 3.1.x/3.2.x
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2002-05-08 10:16 UTC by Jason Thorpe
Modified: 2003-12-17 20:41 UTC (History)
2 users (show)

See Also:
Host: i386-netbsdelf
Target: sh-linux
Build: i386-netbsdelf
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Thorpe 2002-05-08 10:16:00 UTC
The sh-linux compiler fails to build _muldi3 in libgcc:

cc1: RTL flag check: access macro used with unexpected rtx code `const_int' in nonmemory_operand, at recog.c:1222

Release:
3.2 20020507

Environment:
i386-netbsdelf host and sh-linux target

How-To-Repeat:
Attempt to build a sh-linux compiler.
Comment 1 Jason Thorpe 2002-05-08 10:16:00 UTC
Fix:
Unknown.  Building _muldi3 without optmization also fails.
Comment 2 Dara Hazeghi 2003-05-09 19:59:18 UTC
From: Dara Hazeghi <dhazeghi@yahoo.com>
To: gcc-gnats@gcc.gnu.org, thorpej@wasabisystems.com
Cc:  
Subject: Re: target/6606: [SH]sh-linux compiler fails to build libgcc
Date: Fri, 9 May 2003 19:59:18 -0700

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit- 
 trail&database=gcc&pr=6606
 
 Hello,
 
 this bug report is quite old. Would it be possible to check if the  
 problem still occurs in a more current version of gcc (ie 3.2.3)?  
 Thanks,
 
 Dara
 
Comment 3 Dara Hazeghi 2003-05-10 01:33:45 UTC
From: Dara Hazeghi <dhazeghi@yahoo.com>
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: Re: target/6606: [SH]sh-linux compiler fails to build libgcc
Date: Sat, 10 May 2003 01:33:45 -0700

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit- 
 trail&database=gcc&pr=6606
 
 Update:
 
 I have successfully built gcc 3.2.3, 3.3 branch, and mainline as  
 i686-linux to sh-linux cross compilers, all of which manage to build  
 mulddi3 without any problem. It appears this bug is probably fixed.
 
 Dara
Comment 4 Giovanni Bajo 2003-05-10 07:45:35 UTC
State-Changed-From-To: open->feedback
State-Changed-Why: See Dara's question.
Comment 5 Dara Hazeghi 2003-06-16 19:18:49 UTC
Can't reproduce this with gcc 3.2 release either (i686-linux x sh-linux cross compiler) with 
checking enabled. Jason, can you still reproduce this? What flags did you compile with to get the 
ICE?
Comment 6 Jason Thorpe 2003-06-16 19:47:50 UTC
Subject: Re:  [SH]sh-linux compiler fails to build libgcc


On Monday, June 16, 2003, at 12:18  PM, dhazeghi@yahoo.com wrote:

> Can't reproduce this with gcc 3.2 release either (i686-linux x 
> sh-linux cross compiler) with
> checking enabled. Jason, can you still reproduce this? What flags did 
> you compile with to get the
> ICE?

It was during a normal gcc build.

I would suggest that all of my SH-related PRs can be closed.  I'm 
almost certain all of them have been addressed.

         -- Jason R. Thorpe <thorpej@wasabisystems.com>

Comment 7 Dara Hazeghi 2003-06-16 20:37:46 UTC
Closed per Jason's comments (thanks!): http://gcc.gnu.org/ml/gcc-bugs/2003-06/
msg01833.html