Bug 65915 - [6 Regression] FAIL: gcc.target/i386/avx512f-vrndscalepd-2.c (internal compiler error)
Summary: [6 Regression] FAIL: gcc.target/i386/avx512f-vrndscalepd-2.c (internal compil...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 6.0
: P3 normal
Target Milestone: 6.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 65983 65986 65989 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-28 11:51 UTC by H.J. Lu
Modified: 2015-05-05 17:05 UTC (History)
2 users (show)

See Also:
Host:
Target: x86_64-*-*
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2015-04-28 11:51:33 UTC
On x86-64, r222470 caused:

[hjl@gnu-ivb-1 gcc]$ ./xgcc -B./ /export/gnu/import/git/gcc-regression/gcc/gcc/testsuite/gcc.target/i386/avx512f-vrndscalepd-2.c  -fpic -mcmodel=medium   -fno-diagnostics-show-caret -fdiagnostics-color=never   -O2 -mavx512f  -S
/export/gnu/import/git/gcc-regression/gcc/gcc/testsuite/gcc.target/i386/avx512f-vrndscalepd-2.c: In function \u2018test_512\u2019:
/export/gnu/import/git/gcc-regression/gcc/gcc/testsuite/gcc.target/i386/avx512f-vrndscalepd-2.c:101:1: error: insn does not satisfy its constraints:
(insn 367 366 319 9 (set (reg:V2DF 53 xmm16 [ D.29386 ])
        (vec_merge:V2DF (vec_duplicate:V2DF (float:DF (reg:SI 2 cx [orig:96 D.29385 ] [96])))
            (reg:V2DF 53 xmm16 [ D.29386 ])
            (const_int 1 [0x1]))) 2191 {sse2_cvtsi2sd}
     (expr_list:REG_DEAD (reg:SI 2 cx [orig:96 D.29385 ] [96])
        (nil)))
/export/gnu/import/git/gcc-regression/gcc/gcc/testsuite/gcc.target/i386/avx512f-vrndscalepd-2.c:101:1: internal compiler error: in extract_constrain_insn, at recog.c:2244
0xcf4a34 _fatal_insn(char const*, rtx_def const*, char const*, int, char const*)
	../../../../gcc/gcc/rtl-error.c:110
0xcf4a94 _fatal_insn_not_found(rtx_def const*, char const*, int, char const*)
	../../../../gcc/gcc/rtl-error.c:121
0xca7059 extract_constrain_insn(rtx_insn*)
	../../../../gcc/gcc/recog.c:2244
0xcb5847 copyprop_hardreg_forward_1
	../../../../gcc/gcc/regcprop.c:793
0xcb704b execute
	../../../../gcc/gcc/regcprop.c:1289
Please submit a full bug report,
with preprocessed source if appropriate.
Please include the complete backtrace with any bug report.
See <http://gcc.gnu.org/bugs.html> for instructions.
[hjl@gnu-ivb-1 gcc]$
Comment 1 H.J. Lu 2015-04-28 11:53:20 UTC
Total regressions with -fpic -mcmodel=medium are:

FAIL: gcc.target/i386/avx512f-vrndscalepd-2.c (internal compiler error)
FAIL: gcc.target/i386/avx512f-vrndscalepd-2.c (test for excess errors)
FAIL: gcc.target/i386/avx512f-vrndscaleps-2.c (internal compiler error)
FAIL: gcc.target/i386/avx512f-vrndscaleps-2.c (test for excess errors)
FAIL: gcc.target/i386/avx512vl-vrndscaleps-2.c (internal compiler error)
FAIL: gcc.target/i386/avx512vl-vrndscaleps-2.c (test for excess errors)
Comment 2 Uroš Bizjak 2015-05-03 09:03:02 UTC
*** Bug 65989 has been marked as a duplicate of this bug. ***
Comment 3 Uroš Bizjak 2015-05-03 09:04:12 UTC
*** Bug 65986 has been marked as a duplicate of this bug. ***
Comment 4 tocarip 2015-05-05 15:43:45 UTC
Author: tocarip
Date: Tue May  5 15:43:13 2015
New Revision: 222811

URL: https://gcc.gnu.org/viewcvs?rev=222811&root=gcc&view=rev
Log:
PR target/65915
* config/i386/i386.md (vector convert to float spltiter): Check for
xmm16+, when splitting scalar float conversion.
* config/i386/sse.md (sse2_cvtsi2sd): Support EVEX version.

testsuite/ChangeLog:

PR target/65915
* gcc.target/i386/pr65915.c: New.


Added:
    trunk/gcc/testsuite/gcc.target/i386/pr65915.c
Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/i386/i386.md
    trunk/gcc/config/i386/sse.md
    trunk/gcc/testsuite/ChangeLog
Comment 5 Uroš Bizjak 2015-05-05 17:03:45 UTC
*** Bug 65983 has been marked as a duplicate of this bug. ***
Comment 6 Uroš Bizjak 2015-05-05 17:05:29 UTC
Fixed.