User account creation filtered due to spam.

Bug 6243 - testsuite fails almost all tests due to no libintl in LD_LIBRARY_PATH during test.
Summary: testsuite fails almost all tests due to no libintl in LD_LIBRARY_PATH during ...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: 3.3.3
Assignee: Not yet assigned to anyone
URL:
Keywords: build
: 11257 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-04-09 21:16 UTC by tilps
Modified: 2003-12-11 01:21 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-11-25 07:39:35


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tilps 2002-04-09 21:16:00 UTC
When the testsuite is run I get numerous failures after the first 2 tests.
Each and everyone fails due to loader being unable to mab libintl.so
a similar problem is aparent with boehm-gc - but changing 
the LD_LIBRARY_PATH variable in its makefile means it can
complete the test properly.  However I cant work out how I 
can possibly change the way the LD_LIBRARY_PATH is being
modified in the libstdc++-v3 testsuite.  i found ld_library_path
in one of the main .exp files, but modifying that didnt 
solve the problem.

Release:
3.2-CVS

Environment:
alphaev56-dec-osf4.0d

How-To-Repeat:
simply run the testsuite? - maybe theres something odd with
my configuration... any additional information I can provide 
just ask.
Comment 1 Benjamin Kosnik 2003-05-23 03:30:37 UTC
You'll need to add bits like Irix. See

libstdc++-v3/testsuite/lib/libstdc++-v3.dg

-benjamin
Comment 2 tilps 2003-05-25 05:06:32 UTC
I dont think this is the case.
LD_LIBRARY_PATH is the correct environment variable, unlike on irix.  The issue
here is really that LD_LIBRARY_PATH is being replaced rather then prepended too.
Therefore the LD_LIBRARY_PATH which i have setup is ignored.  Without the
existing LD_LIBRRARY_PATH, there is no way for things to succeed as the
libraries which gcc depends on, may not be found by the loader.  libintl is not
a standard library on these machines, I compiled it myself - and as a user
without root access, i have set up a fairly extensive set of programs living in
my home directory.  For this reason I think the testsuite should respect
existing LD_LIBRARY_PATH.

I am however recompiling a new copy of gcc for the purposes of testing it again.
Comment 3 Andrew Pinski 2003-06-28 04:20:24 UTC
There might be other ones like this on too, I just looked in libstdc++-v3/testsuite/lib/
libstdc++-v3-dg.exp on the mainline (20030628) and it replaces 
LD_LIBRARY_PATH.
Comment 4 Andrew Pinski 2003-06-28 04:22:50 UTC
*** Bug 11257 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Pinski 2003-06-28 04:29:47 UTC
The same problem also happens in 
gcc/testsuite/lib{g++,g77,objc}.exp but it is fixed in libjava/testsuite/lib/libjava.exp, the 
code from there should be copied to the other ones.
Comment 6 CVS Commits 2003-12-11 01:08:19 UTC
Subject: Bug 6243

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	bkoz@gcc.gnu.org	2003-12-11 01:08:14

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	2003-12-10  Benjamin Kosnik  <bkoz@redhat.com>
	
	PR libstdc++/6243
	* testsuite/lib/libstdc++.exp (v3-init): Add
	original_ld_library_path, calculate ld_library path, set
	LD_LIBRARY_PATH to both. Based on libjava.exp.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.2151&r2=1.2152
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&r1=1.13&r2=1.14

Comment 7 CVS Commits 2003-12-11 01:19:07 UTC
Subject: Bug 6243

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_3-branch
Changes by:	bkoz@gcc.gnu.org	2003-12-11 01:19:00

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/testsuite/lib: libstdc++-v3-dg.exp 

Log message:
	2003-12-10  Benjamin Kosnik  <bkoz@redhat.com>
	
	PR libstdc++/6243
	* testsuite/lib/libstdc++.exp (v3-init): Add
	original_ld_library_path, calculate ld_library path, set
	LD_LIBRARY_PATH to both. Based on libjava.exp.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.1464.2.160&r2=1.1464.2.161
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++-v3-dg.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.19.20.2&r2=1.19.20.3

Comment 8 Andrew Pinski 2003-12-11 01:21:14 UTC
Fixed in 3.3.3.