Bug 61331 - [ARM] GCC build broken since r210964/r210965
Summary: [ARM] GCC build broken since r210964/r210965
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 5.0
: P3 normal
Target Milestone: 5.0
Assignee: Not yet assigned to anyone
URL:
Keywords: build
Depends on:
Blocks:
 
Reported: 2014-05-27 14:58 UTC by christophe.lyon
Modified: 2014-07-10 09:07 UTC (History)
3 users (show)

See Also:
Host:
Target: arm*
Build:
Known to work: 4.9.0
Known to fail: 4.10.0
Last reconfirmed:


Attachments
unwind-arm.i (6.93 KB, text/plain)
2014-05-27 14:58 UTC, christophe.lyon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christophe.lyon 2014-05-27 14:58:14 UTC
Build of GCC trunk is broken since commits 210964 and 210965 for ARM targets.

$ /work1/lyon/Work/ARM/Linaro/builds/gcc-fsf-trunk/obj-arm-none-linux-gnueabihf/gcc1/./gcc/xgcc -B/work1/lyon/Work/ARM/Linaro/builds/gcc-fsf-trunk/obj-arm-none-linux-gnueabihf/gc\
c1/./gcc/ -B/work1/lyon/Work/ARM/Linaro/builds/gcc-fsf-trunk/tools/arm-none-linux-gnueabihf/bin/ -B/work1/lyon/Work/ARM/Linaro/builds/gcc-fsf-trunk/tools/arm-none-linux-gnueabihf\
/lib/ -g -O2    -fPIC -fno-inline -g  -fbuilding-libgcc -fno-stack-protector   -fPIC -fno-inline -o unwind-arm.o -fexceptions -c unwind-arm.i -fvisibility=hidden
/work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/libgcc/config/arm/unwind-arm.c: In function '_Unwind_VRS_Pop':                                                              
/work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/libgcc/config/arm/unwind-arm.c:446:1: internal compiler error: in lra_update_insn_recog_data, at lra.c:1363                      }                                                                   ^                                                                               
0x86af74 lra_update_insn_recog_data(rtx_def*)                                                    /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trun/gcc/lra.c:1362                                                                                             
0x881692 eliminate_regs_in_insn 
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/lra-eliminations.c:1077                                                                                              
0x881c44 process_insn_for_elimination  
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/lra-eliminations.c:1344                                                                                              
0x881c44 lra_eliminate(bool,bool)
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/lra-eliminations.c:1408                                                                                              
0x87bc0a lra_constraints(bool) 
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/lra-constraints.c:4049                                                                                               
0x86c84c lra(_IO_FILE*) 
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/lra.c:2332                                                                                                           
0x82b80e do_reload 
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/ira.c:5444                                                                                                           
0x82b80e execute  
        /work1/lyon/Work/ARM/Linaro/sources/gcc-fsf/trunk/gcc/ira.c:5605                                                                                                           

GCC configured with --target=arm-none-linux-gnueabihf --disable-nls --without-headers --with-newlib --disable-shared --disable-threads --disable-libssp --disable-libgomp --disable-libmudflap --disable-libatomic --without-libquadmath --disable-libquadmath --enable-languages=c --with-float=hard --enable-build-with-cxx --with-mode=arm --with-cpu=cortex-a9 --with-fpu=neon
Comment 1 christophe.lyon 2014-05-27 14:58:38 UTC
Created attachment 32865 [details]
unwind-arm.i
Comment 2 Bernd Edlinger 2014-05-28 22:56:20 UTC
Richard,

the build is still broken, even after r211031.

could you please have a look?
Comment 3 rsandifo@gcc.gnu.org 2014-05-29 06:47:11 UTC
(In reply to Bernd Edlinger from comment #2)
> Richard,
> 
> the build is still broken, even after r211031.
> 
> could you please have a look?

r211031 wasn't related to this.  Please see:

https://gcc.gnu.org/ml/gcc-patches/2014-05/msg02312.html

for the patch I'd suggested.
Comment 4 Bernd Edlinger 2014-05-29 07:38:02 UTC
(In reply to rsandifo@gcc.gnu.org from comment #3)
> (In reply to Bernd Edlinger from comment #2)
> > Richard,
> > 
> > the build is still broken, even after r211031.
> > 
> > could you please have a look?
> 
> r211031 wasn't related to this.  Please see:
> 
> https://gcc.gnu.org/ml/gcc-patches/2014-05/msg02312.html
> 
> for the patch I'd suggested.

Ok, this would fix the boot-strap problem.
Are you gonna apply it now?
Comment 5 rsandifo@gcc.gnu.org 2014-05-29 08:00:02 UTC
(In reply to Bernd Edlinger from comment #4)
> (In reply to rsandifo@gcc.gnu.org from comment #3)
> > (In reply to Bernd Edlinger from comment #2)
> > > Richard,
> > > 
> > > the build is still broken, even after r211031.
> > > 
> > > could you please have a look?
> > 
> > r211031 wasn't related to this.  Please see:
> > 
> > https://gcc.gnu.org/ml/gcc-patches/2014-05/msg02312.html
> > 
> > for the patch I'd suggested.
> 
> Ok, this would fix the boot-strap problem.
> Are you gonna apply it now?

It needs to be approved by a maintainer first.
Comment 6 Bernd Edlinger 2014-05-29 08:14:05 UTC
(In reply to rsandifo@gcc.gnu.org from comment #5)
> (In reply to Bernd Edlinger from comment #4)
> > (In reply to rsandifo@gcc.gnu.org from comment #3)
> > > (In reply to Bernd Edlinger from comment #2)
> > > > Richard,
> > > > 
> > > > the build is still broken, even after r211031.
> > > > 
> > > > could you please have a look?
> > > 
> > > r211031 wasn't related to this.  Please see:
> > > 
> > > https://gcc.gnu.org/ml/gcc-patches/2014-05/msg02312.html
> > > 
> > > for the patch I'd suggested.
> > 
> > Ok, this would fix the boot-strap problem.
> > Are you gonna apply it now?
> 
> It needs to be approved by a maintainer first.

well, did not explicitly ask for approval?

The message should be marked as PATCH,
and contain a statement like:

"Boot-strapped and regression-tested on arm-xyz-eabi,
OK for thunk"?
Comment 7 Bernd Edlinger 2014-05-31 13:49:16 UTC
Fixed with r211050.  Thanks!
Comment 8 rsandifo@gcc.gnu.org 2014-06-02 11:33:10 UTC
*** Bug 61353 has been marked as a duplicate of this bug. ***
Comment 9 ktkachov 2014-07-10 09:07:04 UTC
This has been fixed it seems