Bug 5910 - Ada libraries are not built by "make all" from top level.
Ada libraries are not built by "make all" from top level.
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: ada
3.1
: P2 normal
: ---
Assigned To: Not yet assigned to anyone
: build
: 8894 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-10 10:36 UTC by Zack Weinberg
Modified: 2008-07-30 13:12 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2003-05-25 13:48:27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zack Weinberg 2002-03-10 10:36:01 UTC
The Ada libraries and utilities do not get built as part
of a normal bootstrap or cross-compiler build.  One must
enter the gcc subdirectory and perform
"make gnatlib_and_tools".  This procedure is not documented
anywhere.

When Ada is among the selected languages, the top-level
Makefile should recognize gnatlib_and_tools as a build
target, and should include that target in the set of
target libraries built by make all/make bootstrap.

Release:
3.1 20020308 (prerelease)
Comment 1 Joseph S. Myers 2002-03-10 19:03:26 UTC
From: "Joseph S. Myers" <jsm28@cam.ac.uk>
To: <zack@codesourcery.com>
Cc: <gcc-gnats@gcc.gnu.org>,  <gcc-bugs@gcc.gnu.org>
Subject: Re: ada/5910: Ada libraries are not built by "make all" from top
 level.
Date: Sun, 10 Mar 2002 19:03:26 +0000 (GMT)

 On 10 Mar 2002 zack@codesourcery.com wrote:
 
 > "make gnatlib_and_tools".  This procedure is not documented
 > anywhere.
 
 It's documented in the obvious place, gcc/doc/install.texi.  However, it
 should be fixed so that "make bootstrap" at toplevel does it.  (And "make"  
 and "make all" at toplevel should mean the same as "make bootstrap", so
 people don't need a special build procedure for GCC different from that
 for other GNU software, but that's a separate longstanding bug.)
 
 -- 
 Joseph S. Myers
 jsm28@cam.ac.uk
 

Comment 2 Zack Weinberg 2002-03-11 02:04:16 UTC
From: Zack Weinberg <zack@codesourcery.com>
To: "Joseph S. Myers" <jsm28@cam.ac.uk>
Cc: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org
Subject: Re: ada/5910: Ada libraries are not built by "make all" from top level.
Date: Mon, 11 Mar 2002 02:04:16 -0800

 On Sun, Mar 10, 2002 at 07:03:26PM +0000, Joseph S. Myers wrote:
 > On 10 Mar 2002 zack@codesourcery.com wrote:
 > 
 > > "make gnatlib_and_tools".  This procedure is not documented
 > > anywhere.
 > 
 > It's documented in the obvious place, gcc/doc/install.texi.
 
 Sorry, it must have been added after the last time I checked.  Will
 fact check more thoroughly in the future.
 
 > (And "make" and "make all" at toplevel should mean the same as "make
 > bootstrap", so people don't need a special build procedure for GCC
 > different from that for other GNU software, but that's a separate
 > longstanding bug.)
 
 For the record, I agree with this.
 
 zw
Comment 3 Andrew Pinski 2003-07-19 17:45:38 UTC
Most likely gets fixed when PR 5911 is fixed.
Comment 4 Arnaud Charlet 2003-10-21 16:58:30 UTC
This is indeed a duplicate of PR 5911, so I am closing this
one, since there are active discussions happening on 5911.

Arno

*** This bug has been marked as a duplicate of 5911 ***
Comment 5 Arnaud Charlet 2003-10-21 17:05:39 UTC
Removing extra dependency, since PR has been marked as a duplicate.

Arno
Comment 6 Paolo Bonzini 2008-07-30 13:12:16 UTC
reopened just because it is not a dup of PR5911...
Comment 7 Paolo Bonzini 2008-07-30 13:12:37 UTC
... and closed because it was fixed by the introduction of libaad