User account creation filtered due to spam.

Bug 59076 - std::to_string(int ) could not be found in GCC 4.8.2
Summary: std::to_string(int ) could not be found in GCC 4.8.2
Status: RESOLVED DUPLICATE of bug 52015
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.8.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-11 07:36 UTC by chun-fu
Modified: 2013-11-11 11:36 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chun-fu 2013-11-11 07:36:35 UTC
when compile below example code with GCC4.8.2 i got error message reporting to_string was not declared.


#include <iostream>
#include <string>

using namespace std;


int main(int argc, char *argv[]) {
double f = 23.24;
string s = to_string(f);
cout<<s<<endl;
return 0;
}

[Error] 'to_string' was not declared in this scope 


gcc version 4.8.2 (GCC)

compiler options i specified when compiling the program as below:

-std=c++11 -Wall

platform environment:
Win7
Comment 1 Jonathan Wakely 2013-11-11 11:36:13 UTC
See Bug 52015, it's not supported on MinGW because of limitations in the MinGW runtime that need changes from MinGW developers.

*** This bug has been marked as a duplicate of bug 52015 ***