Bug 58418 - [4.9 Regression] wrong code at -O2 and -O3 on x86_64-linux-gnu (in 32-bit mode)
Summary: [4.9 Regression] wrong code at -O2 and -O3 on x86_64-linux-gnu (in 32-bit mode)
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.9.0
: P3 normal
Target Milestone: 4.9.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 58419 58431 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-13 21:04 UTC by Zhendong Su
Modified: 2013-10-30 13:41 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2013-09-13 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zhendong Su 2013-09-13 21:04:16 UTC
The current gcc trunk produces wrong code for the attached testcase on x86_64-linux-gnu when compiled at -O2 and -O3 in 32-bit mode. 

It appears to be a regression from 4.8.x.  


$ gcc-trunk -v
Using built-in specs.
COLLECT_GCC=gcc-trunk
COLLECT_LTO_WRAPPER=/usr/local/gcc-trunk/libexec/gcc/x86_64-unknown-linux-gnu/4.9.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc-trunk/configure --enable-languages=c,c++,objc,obj-c++,fortran,lto --with-gmp=/usr/local/gcc-trunk --with-mpfr=/usr/local/gcc-trunk --with-mpc=/usr/local/gcc-trunk --with-cloog=/usr/local/gcc-trunk --prefix=/usr/local/gcc-trunk
Thread model: posix
gcc version 4.9.0 20130913 (experimental) [trunk revision 202556] (GCC) 
$
$ gcc-trunk -m32 -O1 small.c
$ a.out
0
$ gcc-4.8 -m32 -O2 small.c  
$ a.out
0
$ gcc-trunk -m64 -O2 small.c
$ a.out
0
$ gcc-trunk -m32 -O2 small.c
$ a.out
1
$ 


------------------------------------------


int printf (const char *, ...);

int a, b, *c = &b, d = -1, e, f, *g, *h = &f, **i = &g, j;

unsigned int
foo (unsigned int p)
{
  return p == 0 ? 0 : 1 / p;
}

static int *
bar ()
{
  *c = *h = foo (d) & (-9 < d);
  for (e = 0; e; e++)
    ;
  return 0;
}

int
main ()
{
  for (; j; j++)
    for (;; a--)
      ;
  *i = bar ();
  printf ("%d\n", f);
  return 0;
}
Comment 1 H.J. Lu 2013-09-13 22:01:58 UTC
It is caused by r202468.
Comment 2 Vladimir Makarov 2013-09-16 15:12:24 UTC
Author: vmakarov
Date: Mon Sep 16 15:12:22 2013
New Revision: 202630

URL: http://gcc.gnu.org/viewcvs?rev=202630&root=gcc&view=rev
Log:
2013-09-16  Vladimir Makarov  <vmakarov@redhat.com>

	PR middle-end/58418
	* lra-constraints.c (undo_optional_reloads): Consider all optional
	reload even if it did not get a hard reg.

2013-09-16  Vladimir Makarov  <vmakarov@redhat.com>

	* gcc.target/i386/pr58418.c: New.


Added:
    trunk/gcc/testsuite/gcc.target/i386/pr58418.c
Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/lra-constraints.c
    trunk/gcc/testsuite/ChangeLog
Comment 3 Jeffrey A. Law 2013-09-16 19:29:23 UTC
*** Bug 58431 has been marked as a duplicate of this bug. ***
Comment 4 Richard Biener 2013-09-17 07:52:48 UTC
Fixed.
Comment 5 Richard Biener 2013-10-30 13:41:05 UTC
*** Bug 58419 has been marked as a duplicate of this bug. ***