User account creation filtered due to spam.

Bug 58117 - Java not compiling on ia64-hp-hpux11.31 due to socklen_t
Summary: Java not compiling on ia64-hp-hpux11.31 due to socklen_t
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.7.3
: P3 blocker
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-10 03:33 UTC by Paul A.
Modified: 2015-12-21 03:19 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2015-12-16 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul A. 2013-08-10 03:33:36 UTC
libtool: compile:  /qaapp/src/java/./gcc/xgcc -shared-libgcc -B/qaapp/src/java/./gcc -nostdinc++ -L/qaapp/src/java/ia64-hp-hpux11.31/hpux64/libstdc++-v3/src -L/qaapp/src/java/ia64-hp-hpux11.31/hpux64/libstdc++-v3/src/.libs -B/net/tdcbdv01/rlsemgmt/free/ia64-hp-hpux11.31/bin/ -B/net/tdcbdv01/rlsemgmt/free/ia64-hp-hpux11.31/lib/ -isystem /net/tdcbdv01/rlsemgmt/free/ia64-hp-hpux11.31/include -isystem /net/tdcbdv01/rlsemgmt/free/ia64-hp-hpux11.31/sys-include -mlp64 -DHAVE_CONFIG_H -I. -I/qaapp/src/gcc-4.7.3/libjava -I./include -I./gcj -I/qaapp/src/gcc-4.7.3/libjava -Iinclude -I/qaapp/src/gcc-4.7.3/libjava/include -I/qaapp/src/gcc-4.7.3/libjava/classpath/include -Iclasspath/include -I/qaapp/src/gcc-4.7.3/libjava/classpath/native/fdlibm -I/qaapp/src/gcc-4.7.3/libjava/../boehm-gc/include -I../boehm-gc/include -I/qaapp/src/gcc-4.7.3/libjava/libltdl -I/qaapp/src/gcc-4.7.3/libjava/libltdl -I/qaapp/src/gcc-4.7.3/libjava/.././libjava/../libgcc -I/qaapp/src/gcc-4.7.3/libjava/../zlib -I/qaapp/src/gcc-4.7.3/libjava/../libffi/include -I../libffi/include -fno-rtti -fnon-call-exceptions -fdollars-in-identifiers -Wswitch-enum -D_FILE_OFFSET_BITS=64 -funwind-tables -Wextra -Wall -D_GNU_SOURCE -DPREFIX=\"/net/tdcbdv01/rlsemgmt/free\" -DTOOLEXECLIBDIR=\"/net/tdcbdv01/rlsemgmt/free/lib/hpux64\" -DJAVA_HOME=\"/net/tdcbdv01/rlsemgmt/free\" -DBOOT_CLASS_PATH=\"/net/tdcbdv01/rlsemgmt/free/share/java/libgcj-4.7.3.jar\" -DJAVA_EXT_DIRS=\"/net/tdcbdv01/rlsemgmt/free/share/java/ext\" -DGCJ_ENDORSED_DIRS=\"/net/tdcbdv01/rlsemgmt/free/share/java/gcj-endorsed\" -DGCJ_VERSIONED_LIBDIR=\"/net/tdcbdv01/rlsemgmt/free/lib/hpux64/gcj-4.7.3-13\" -DPATH_SEPARATOR=\":\" -DECJ_JAR_FILE=\"\" -DLIBGCJ_DEFAULT_DATABASE=\"/net/tdcbdv01/rlsemgmt/free/lib/hpux64/gcj-4.7.3-13/classmap.db\" -DLIBGCJ_DEFAULT_DATABASE_PATH_TAIL=\"gcj-4.7.3-13/classmap.db\" -fno-omit-frame-pointer -O2 -g -mlp64 -MT prims.lo -MD -MP -MF .deps/prims.Tpo -c /qaapp/src/gcc-4.7.3/libjava/prims.cc  -fPIC -DPIC -o .libs/prims.o
In file included from /qaapp/src/gcc-4.7.3/libjava/prims.cc:12:0:
./include/platform.h: In function 'int _Jv_accept(int, sockaddr*, socklen_t*)':
./include/platform.h:162:37: error: cannot convert 'socklen_t* {aka long unsigned int*}' to 'int*' for argument '3' to 'int accept(int, void*, int*)'
gmake[5]: *** [prims.lo] Error 1
gmake[5]: *** Waiting for unfinished jobs....
gmake[5]: Leaving directory `/qaapp/src/java/ia64-hp-hpux11.31/hpux64/libjava'
Comment 1 Martin Sebor 2015-12-16 02:44:17 UTC
Is this a problem with one of the recent releases, either 4.9.3 or 5.3, or with trunk?  If not, we should close this bug.
Comment 2 Paul A. 2015-12-20 02:13:22 UTC
On Wed, Dec 16, 2015 at 02:44:17AM +0000, msebor at gcc dot gnu.org wrote:
> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58117
...
> --- Comment #1 from Martin Sebor <msebor at gcc dot gnu.org> ---
> Is this a problem with one of the recent releases, either 4.9.3 or 5.3, or with
> trunk?  If not, we should close this bug.

Sure, go ahead an close it... unfortunately I can neither confirm nor
deny about other versions, since I no longer have access to hpux.
Comment 3 Martin Sebor 2015-12-21 03:19:08 UTC
Closing based on reporter's feedback.