Bug 57732 - [4.8/4.9/5 Regression] ICE (segfault in libisl) building drizzle on 32bit targets (at least arm-linux and i586-linux)
Summary: [4.8/4.9/5 Regression] ICE (segfault in libisl) building drizzle on 32bit tar...
Status: RESOLVED WORKSFORME
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.8.1
: P2 normal
Target Milestone: 4.8.4
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on: 59121
Blocks: graphite
  Show dependency treegraph
 
Reported: 2013-06-27 11:54 UTC by Matthias Klose
Modified: 2014-08-15 15:05 UTC (History)
0 users

See Also:
Host:
Target: arm-linxux-gnueabihf i586-linux-gnu
Build:
Known to work: 4.7.3
Known to fail: 4.8.1, 4.9.0
Last reconfirmed: 2013-11-22 00:00:00


Attachments
preprocessed source (482.56 KB, application/x-xz)
2013-06-27 11:54 UTC, Matthias Klose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Klose 2013-06-27 11:54:47 UTC
Created attachment 30386 [details]
preprocessed source

g++ -c -g -O2 -std=gnu++98 -fPIE -floop-parallelize-all -fno-strict-aliasing  cmpfunc.ii 

leaving out the -floop-parallelize-all avoids the ICE.

(gdb) bt
#0  0xf7f5859c in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#1  0xf7f58629 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#2  0xf7f512b7 in isl_tab_rollback () from /usr/lib/i386-linux-gnu/libisl.so.10
#3  0xf7f5307b in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#4  0xf7f59376 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#5  0xf7f59355 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#6  0xf7f59355 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#7  0xf7f59355 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#8  0xf7f5a283 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#9  0xf7f5a506 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#10 0xf7f5ac09 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#11 0xf7efb5b2 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#12 0xf7f0d3d3 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#13 0xf7f0e067 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#14 0xf7ee0728 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#15 0xf7ee07f3 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#16 0xf7ee16e9 in isl_access_info_compute_flow () from /usr/lib/i386-linux-gnu/libisl.so.10
#17 0xf7ee1f09 in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#18 0xf7f61d6a in ?? () from /usr/lib/i386-linux-gnu/libisl.so.10
#19 0xf7ee9d21 in isl_hash_table_foreach () from /usr/lib/i386-linux-gnu/libisl.so.10
#20 0xf7f62c4e in isl_union_map_foreach_map () from /usr/lib/i386-linux-gnu/libisl.so.10
#21 0xf7ee228c in isl_union_map_compute_flow () from /usr/lib/i386-linux-gnu/libisl.so.10
#22 0x088c9ee7 in compute_deps(scop*, vec<poly_bb*, va_heap, vl_ptr>, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**, isl_union_map**) ()
#23 0x088ca821 in loop_is_parallel_p(loop*, htab*, int) ()
#24 0x088c8d15 in ?? ()
#25 0x088c8c02 in ?? ()
#26 0x088c9390 in gloog(scop*, htab*) ()
#27 0x088c62db in graphite_transform_loops() ()
#28 0x085ec5a4 in ?? ()
#29 0x08497fae in execute_one_pass(opt_pass*) ()
#30 0x08498385 in execute_pass_list(opt_pass*) ()
#31 0x08498398 in execute_pass_list(opt_pass*) ()
#32 0x08498398 in execute_pass_list(opt_pass*) ()
#33 0x08498398 in execute_pass_list(opt_pass*) ()
#34 0x082dc43b in ?? ()
#35 0x082dda15 in compile() ()
#36 0x082dde9a in finalize_compilation_unit() ()
#37 0x081a82ad in cp_write_global_declarations() ()
#38 0x0852c96d in ?? ()
#39 0x0852e454 in toplev_main(int, char**) ()
Comment 1 Jakub Jelinek 2013-10-16 09:50:24 UTC
GCC 4.8.2 has been released.
Comment 2 Richard Biener 2013-11-22 10:52:05 UTC
Cannot reproduce this one, but it looks like a dup of or related to PR59121.

As the crash is in ISL please report the ISL and cloog versions you use.
Comment 3 Jackie Rosen 2014-02-16 13:16:54 UTC Comment hidden (spam)
Comment 4 Richard Biener 2014-05-22 09:04:08 UTC
GCC 4.8.3 is being released, adjusting target milestone.
Comment 5 Matthias Klose 2014-08-15 15:05:30 UTC
can't see this anymore with the current 4.8 branch (and 4.9)