Bug 57591 - gcc-4.8 libbacktrace btest failure on Linux ppc64
Summary: gcc-4.8 libbacktrace btest failure on Linux ppc64
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: libbacktrace (show other bugs)
Version: 4.8.1
: P3 major
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-12 00:27 UTC by acrux
Modified: 2019-02-09 12:57 UTC (History)
6 users (show)

See Also:
Host: powerpc64-unknown-linux-gnu
Target: powerpc64-unknown-linux-gnu
Build: powerpc64-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
full log (360.32 KB, application/x-gzip-compressed)
2013-06-12 00:27 UTC, acrux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description acrux 2013-06-12 00:27:21 UTC
Created attachment 30297 [details]
full log

btest fails building on Linux ppc64 (CRUX PPC 64bit). I tried gcc-4.8.0,gcc-4.8.1,gcc-4.8-20130606. I also tried it on ppc but on 32bit environment it builds fine. 

system: IBM POWER4+ ,kernel Linux-3.4.48, powerpc64-unknown-linux-gnu
toolcahin: gcc-4.7.3, binutils-2.23.2, glibc-2.16.0, libgmp-5.1.2, libmpfr-3.1.2, libmpc-1.0.1, libcloog-0.18.0, libppl-1.1pre8


configure: --enable-bootstrap --with-cpu=default64 --prefix=/usr --mandir=/usr/man --libexecdir=/usr/lib --enable-languages=c,c++,objc --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-shared --enable-lto --disable-ppl --disable-cloog --disable-isl --disable-nls --with-x=no --enable-long-long --with-system-zlib '--with-pkgversion=CRUX PPC' --host=powerpc64-unknown-linux-gnu --build=powerpc64-unknown-linux-gnu --target=powerpc64-unknown-linux-gnu


[...]
make[2]: Leaving directory `/root/1up/gcc/work/src/build/intl'
make[2]: Entering directory `/root/1up/gcc/work/src/build/libbacktrace'
true  DO=all multi-do # make
make  btest
make[3]: Entering directory `/root/1up/gcc/work/src/build/libbacktrace'
gcc -DHAVE_CONFIG_H -I. -I../../gcc-4.8.1/libbacktrace  -I ../../gcc-4.8.1/libbacktrace/../include -I ../../gcc-4.8.1/libbacktrace/../libgcc -I ../libgcc  -funwind-tables -frandom-seed=btest-btest.o -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wmissing-format-attribute -Wcast-qual  -g -O -O2 -mcpu=powerpc64 -pipe -c -o btest-btest.o `test -f 'btest.c' || echo '../../gcc-4.8.1/libbacktrace/'`btest.c
/bin/sh ./libtool --tag=CC   --mode=link gcc -funwind-tables -frandom-seed=btest -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wmissing-format-attribute -Wcast-qual  -g -O -O2 -mcpu=powerpc64 -pipe   -o btest btest-btest.o libbacktrace.la 
libtool: link: gcc -funwind-tables -frandom-seed=btest -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wmissing-format-attribute -Wcast-qual -g -O -O2 -mcpu=powerpc64 -pipe -o btest btest-btest.o  ./.libs/libbacktrace.a
make[3]: Leaving directory `/root/1up/gcc/work/src/build/libbacktrace'
make  check-TESTS
make[3]: Entering directory `/root/1up/gcc/work/src/build/libbacktrace'
test3: [0]: NULL syminfo name
test3: [1]: NULL syminfo name
test3: [2]: NULL syminfo name
PASS: backtrace_full noinline
PASS: backtrace_full inline
FAIL: backtrace_simple noinline
PASS: backtrace_simple inline
FAIL: btest
==================
1 of 1 test failed
==================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory `/root/1up/gcc/work/src/build/libbacktrace'
make[2]: *** [check-am] Error 2
make[2]: Target `check' not remade because of errors.
make[2]: Leaving directory `/root/1up/gcc/work/src/build/libbacktrace'
make[1]: *** [check-libbacktrace] Error 2
[...]

full log attached (log.0.gz)
Comment 1 acrux 2013-07-04 05:20:05 UTC
same failure with  gcc-4.8-20130620 and gcc-4.8-20130627
Comment 2 acrux 2013-07-08 19:09:15 UTC
same failure with  gcc-4.8-20130704
Comment 3 acrux 2013-07-17 20:49:14 UTC
same failure with  gcc-4.8-20130711
Comment 4 acrux 2013-07-22 12:05:45 UTC
same failure with  gcc-4.8-20130718
Comment 5 acrux 2013-07-31 16:37:45 UTC
same failure with  gcc-4.8-20130725
Comment 6 Segher Boessenkool 2019-02-09 12:40:14 UTC
4.8 is no longer supported (and neither are 4.9, 5, or 6).  I'm closing this
bug; please reopen it if it still happens (with trunk or another supported
version).  Thanks!
Comment 7 Tom de Vries 2019-02-09 12:57:42 UTC
(In reply to Segher Boessenkool from comment #6)
> please reopen it if it still happens (with trunk or another supported
> version).  Thanks!

And if it still happens, please attach the log for the failing test-case: btest.log.

Thanks,
- Tom