User account creation filtered due to spam.

Bug 57194 - go binaries give "no debug info in ELF executable errno -1"
Summary: go binaries give "no debug info in ELF executable errno -1"
Status: RESOLVED DUPLICATE of bug 64595
Alias: None
Product: gcc
Classification: Unclassified
Component: go (show other bugs)
Version: unknown
: P3 normal
Target Milestone: ---
Assignee: Ian Lance Taylor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-07 11:05 UTC by Allan McRae
Modified: 2015-02-03 20:05 UTC (History)
3 users (show)

See Also:
Host:
Target: x86_64-unknown-linux-gnu
Build:
Known to work: 4.7.3
Known to fail: 4.8.0, 4.9.0
Last reconfirmed: 2013-05-07 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Allan McRae 2013-05-07 11:05:12 UTC
Since revision r195931, running anything compiled with gccgo without any compile flags gives:

# ./a.out 
no debug info in ELF executable errno -1
fatal error: no debug info in ELF executable

Adding "-g" to the compile line results in a working binary, but stripping this binary results in the same error.
Comment 1 Ian Lance Taylor 2013-05-07 18:47:42 UTC
Note that in general Go requires debug info.  It will not work to build a Go program without -g, nor will it work to strip a Go program.
Comment 2 gp 2013-05-09 07:41:53 UTC
IMHO, this is nevertheless a bug. If the debug info must stay, they should be unstrippable. Moreover, gcc should add the -g flag "silently".
Comment 3 Christopher Meng 2013-08-08 08:45:47 UTC
+1.

I'm building snowbox(go program), and also it threw out such errors after running.
Comment 4 Ian Lance Taylor 2015-02-03 20:05:28 UTC
This was reopened later, and is now fixed.

*** This bug has been marked as a duplicate of bug 64595 ***