Bug 56258 - Please upgrade doc/*.texi to the latest texinfo package(s)
Summary: Please upgrade doc/*.texi to the latest texinfo package(s)
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.8.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 56663 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-08 21:07 UTC by Denis Excoffier
Modified: 2013-03-24 07:06 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
patch to fix gcc-4_7-branch bootstrap against texinfo 5.0 (1.08 KB, patch)
2013-02-22 02:01 UTC, Jack Howarth
Details | Diff
backport of gcc-4_7-branch fixes to gcc-4_6-branch (970 bytes, patch)
2013-02-22 02:03 UTC, Jack Howarth
Details | Diff
complete gcc-4_6-branch fixes for bootstrap against texinfo 5.0 (1.15 KB, patch)
2013-02-22 04:59 UTC, Jack Howarth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Excoffier 2013-02-08 21:07:15 UTC
Bootstrap fails if the last texinfo (currently 4.13.96) is used (this was also
the case with at least 4.13.94 and 4.13.95). It seems that messages
like:

.../install.texi:3133: warning: @anchor should not appear in @heading

or

.../gcc.texi:88: warning: @tex should only appear at a line beginning

make the building of doc/gcc.info to fail. Prepending "-" in front of the
building rule in gcc/Makefile solves the issue, but gcc.info does not get
installed (of course). Plain texinfo-4.13 is OK. I tried with gcc-4.8-20130203
under x86_64-apple-darwin12.2.0 but i suppose this is platform independent.

Please upgrade the *.texi files in order to be able to cope with the most
recent (even alpha) texinfo releases. This is also applicable to the
soon-to-be-released GCC 4.7.3.

Also, perhaps texinfo should be listed in install/prerequisites.html.

Regards,

Denis Excoffier.
Comment 1 Richard Biener 2013-02-10 12:26:35 UTC
It's not needed if you use the release tarballs as we include the .info files
in the tarball.  It's required for snapshots though.
Comment 2 Bruce Dubbs 2013-02-18 21:31:45 UTC
texinfo-5.0 has been released and breaks the gcc info page generation.  For LFS, we are disabling these files until the texi files are fixed:

sed -i 's/BUILD_INFO=info/BUILD_INFO=/' gcc/configure
Comment 3 Jakub Jelinek 2013-02-20 12:07:36 UTC
http://koji.fedoraproject.org/koji/getfile?taskID=5033640&name=build.log
lists lots of warnings and some errors.

--- gcc/ada/gnat-style.texi.jj	2012-08-10 12:57:33.000000000 +0200
+++ gcc/ada/gnat-style.texi	2013-02-20 13:06:03.042667300 +0100
@@ -42,7 +42,7 @@ Texts.  A copy of the license is include
 @titlepage
 @titlefont{GNAT Coding Style:}
 @sp 1
-@title @hfill A Guide for GNAT Developers
+@title A Guide for GNAT Developers
 @subtitle GNAT, The GNU Ada Compiler
 @versionsubtitle
 @author Ada Core Technologies, Inc.
--- gcc/doc/invoke.texi.jj	2013-01-31 22:57:22.000000000 +0100
+++ gcc/doc/invoke.texi	2013-02-20 13:06:47.516405739 +0100
@@ -5612,7 +5612,7 @@ Dump after the peephole pass.
 @opindex fdump-rtl-postreload
 Dump after post-reload optimizations.
 
-@itemx -fdump-rtl-pro_and_epilogue
+@item -fdump-rtl-pro_and_epilogue
 @opindex fdump-rtl-pro_and_epilogue
 Dump after generating the function prologues and epilogues.

is an untested guess for fixing the errors.
Comment 4 Jakub Jelinek 2013-02-21 09:41:05 UTC
Author: jakub
Date: Thu Feb 21 09:40:44 2013
New Revision: 196196

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=196196
Log:
	PR bootstrap/56258
	* doc/invoke.texi (-fdump-rtl-pro_and_epilogue): Use @item
	instead of @itemx.

	* gnat-style.texi (@title): Remove @hfill.
	* projects.texi: Avoid line wrapping inside of @pxref or
	@xref.

	* doc/cp-tools.texinfo (Virtual Machine Options): Use just
	one @gccoptlist instead of 3 separate ones.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/ada/ChangeLog
    trunk/gcc/ada/gnat-style.texi
    trunk/gcc/ada/projects.texi
    trunk/gcc/doc/invoke.texi
    trunk/libjava/classpath/ChangeLog.gcj
    trunk/libjava/classpath/doc/cp-tools.texinfo
Comment 5 Jakub Jelinek 2013-02-21 09:43:00 UTC
Author: jakub
Date: Thu Feb 21 09:42:39 2013
New Revision: 196197

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=196197
Log:
	PR bootstrap/56258
	* doc/invoke.texi (-fdump-rtl-pro_and_epilogue): Use @item
	instead of @itemx.

	* gnat-style.texi (@title): Remove @hfill.
	* projects.texi: Avoid line wrapping inside of @pxref or
	@xref.

	* doc/cp-tools.texinfo (Virtual Machine Options): Use just
	one @gccoptlist instead of 3 separate ones.

Modified:
    branches/gcc-4_7-branch/gcc/ChangeLog
    branches/gcc-4_7-branch/gcc/ada/ChangeLog
    branches/gcc-4_7-branch/gcc/ada/gnat-style.texi
    branches/gcc-4_7-branch/gcc/ada/projects.texi
    branches/gcc-4_7-branch/gcc/doc/invoke.texi
    branches/gcc-4_7-branch/libjava/classpath/ChangeLog.gcj
    branches/gcc-4_7-branch/libjava/classpath/doc/cp-tools.texinfo
Comment 6 Jakub Jelinek 2013-02-21 09:56:07 UTC
Author: jakub
Date: Thu Feb 21 09:56:01 2013
New Revision: 196198

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=196198
Log:
	PR bootstrap/56258
	* doc/invoke.texi (-fdump-rtl-pro_and_epilogue): Use @item
	instead of @itemx.

	* gnat-style.texi (@title): Remove @hfill.
	* projects.texi: Avoid line wrapping inside of @pxref or
	@xref.

	* doc/cp-tools.texinfo (Virtual Machine Options): Use just
	one @gccoptlist instead of 3 separate ones.

Modified:
    branches/gcc-4_6-branch/gcc/ChangeLog
    branches/gcc-4_6-branch/gcc/ada/ChangeLog
    branches/gcc-4_6-branch/gcc/ada/gnat-style.texi
    branches/gcc-4_6-branch/gcc/ada/projects.texi
    branches/gcc-4_6-branch/gcc/doc/invoke.texi
    branches/gcc-4_6-branch/libjava/classpath/ChangeLog.gcj
    branches/gcc-4_6-branch/libjava/classpath/doc/cp-tools.texinfo
Comment 7 Jack Howarth 2013-02-22 02:01:10 UTC
Created attachment 29520 [details]
patch to fix gcc-4_7-branch bootstrap against texinfo 5.0

Current gcc-4_7-branch still fails to bootstrap against texinfo 5.0 due to additional instances of @itemx. The attached patch fixes these and bootstraps on x86_64-apple-darwin12.
Comment 8 Jack Howarth 2013-02-22 02:03:14 UTC
Created attachment 29521 [details]
backport of gcc-4_7-branch fixes to gcc-4_6-branch

The attached patch backports the additional fixes to gcc-4_6-branch.
Comment 9 Jack Howarth 2013-02-22 04:59:53 UTC
Created attachment 29522 [details]
complete gcc-4_6-branch fixes for bootstrap against texinfo 5.0

One additional fix (present in gcc-4_7-branch and trunk) is required for bootstrapping gcc-4_6-branch against texinfo 5.0. Tested on x86_64-apple-darwin11.
Comment 10 Jack Howarth 2013-02-22 15:19:19 UTC
Posted patches of remaining bootstrap fixes for gcc-4_7-branch and gcc-4_6-branch...

http://gcc.gnu.org/ml/gcc-patches/2013-02/msg01059.html
http://gcc.gnu.org/ml/gcc-patches/2013-02/msg01060.html
Comment 11 Denis Excoffier 2013-03-10 08:06:54 UTC
Please to find someone able to apply the above patches on branches 4.6 and 4.7?
Comment 12 Richard Biener 2013-03-20 11:02:42 UTC
*** Bug 56663 has been marked as a duplicate of this bug. ***
Comment 13 Richard Biener 2013-03-20 11:09:04 UTC
I have applied the patch for the 4.7/4.6 branches now.  Thus this is fixed
(hopefully).
Comment 14 Richard Biener 2013-03-20 11:16:14 UTC
Author: rguenth
Date: Wed Mar 20 11:06:35 2013
New Revision: 196819

URL: http://gcc.gnu.org/viewcvs?rev=196819&root=gcc&view=rev
Log:
2013-03-20  Jack Howarth  <howarth@bromo.med.uc.edu>

	PR bootstrap/56258
	* doc/generic.texi (POINTER_PLUS_EXPR): Use @item instead of @itemx.
	(PLUS_EXPR): Likewise.
	* doc/cppopts.texi (--help): Likewise.
	* doc/invoke.texi (-fenable-@var{kind}-@var{pass}): Likewise.
	(-fdump-rtl-cprop_hardreg): Likewise.
	(-fdump-rtl-csa): Likewise.
	(-fdump-rtl-dce): Likewise.
	(-fdump-rtl-dbr): Likewise.
	(-fdump-rtl-into_cfglayout): Likewise.
	(-fdump-rtl-outof_cfglayout): Likewise.

Modified:
    branches/gcc-4_7-branch/gcc/ChangeLog
    branches/gcc-4_7-branch/gcc/doc/cppopts.texi
    branches/gcc-4_7-branch/gcc/doc/generic.texi
    branches/gcc-4_7-branch/gcc/doc/invoke.texi
Comment 15 Richard Biener 2013-03-20 11:16:42 UTC
Author: rguenth
Date: Wed Mar 20 11:08:52 2013
New Revision: 196820

URL: http://gcc.gnu.org/viewcvs?rev=196820&root=gcc&view=rev
Log:
2013-03-20  Jack Howarth  <howarth@bromo.med.uc.edu>

	PR bootstrap/56258
	* doc/generic.texi (POINTER_PLUS_EXPR): Use @item instead of @itemx.
	(PLUS_EXPR): Likewise.
	* doc/cppopts.texi (--help): Likewise.
	* doc/invoke.texi (-fenable-@var{kind}-@var{pass}): Likewise
	(-fdump-rtl-cprop_hardreg): Likewise.
	(-fdump-rtl-csa): Likewise.
	(-fdump-rtl-dce): Likewise.
	(-fdump-rtl-dbr): Likewise.
	(-fdump-rtl-into_cfglayout): Likewise.
	(-fdump-rtl-outof_cfglayout): Likewise.
	(@gccoptlist): Move misplaced bracket.

Modified:
    branches/gcc-4_6-branch/gcc/ChangeLog
    branches/gcc-4_6-branch/gcc/doc/cppopts.texi
    branches/gcc-4_6-branch/gcc/doc/generic.texi
    branches/gcc-4_6-branch/gcc/doc/invoke.texi
Comment 16 Denis Excoffier 2013-03-24 07:06:40 UTC
Bootstrap of gcc-4.7-20130323 works perfectly. Thanks.