Bug 55706 - [4.8 Regression] failure to build libstdc++ in stage 1
Summary: [4.8 Regression] failure to build libstdc++ in stage 1
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.8.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-15 10:46 UTC by Rainer Emrich
Modified: 2013-09-05 15:53 UTC (History)
1 user (show)

See Also:
Host: x86_64-w64-mingw32
Target: x86_64-w64-mingw32
Build: x86_64-w64-mingw32
Known to work:
Known to fail:
Last reconfirmed:


Attachments
error log (11.19 KB, application/octet-stream)
2012-12-15 10:46 UTC, Rainer Emrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Emrich 2012-12-15 10:46:00 UTC
Created attachment 28976 [details]
error log

There are a lot of failures, huge error log attached.

For me it looks like the root cause is the following:

libstdc++-v3/include/bits/basic_string.h:2971:22: note:   mismatched types 'std::size_t {aka long long unsigned int}' and 'const wchar_t*'

That causes for example
error: no matching function for call to '__to_xstring(int (*)(wchar_t*, const wchar_t*, char*), long long unsigned int, const wchar_t [3], unsigned int&)'

an leads to template argument deduction/substitution failed.
Comment 1 Jonathan Wakely 2012-12-15 12:43:15 UTC
This implies the type of std::vswprintf is wrong on that platform.
Comment 2 Jonathan Wakely 2012-12-15 12:47:13 UTC
Ah of course, this is the fix for PR 52015

You need to use at least r5437 from the Mingw-w64 trunk for 4.8, I will update the release notes today
Comment 3 Jonathan Wakely 2012-12-15 13:08:13 UTC
This is now documented http://gcc.gnu.org/gcc-4.8/changes.html#targets
Comment 4 roger pack 2013-09-05 14:16:35 UTC
(as a note, appears mingw-w64 2.0.8 is not sufficient you need something newer...)
Comment 5 Jonathan Wakely 2013-09-05 14:33:27 UTC
(In reply to roger pack from comment #4)
> (as a note, appears mingw-w64 2.0.8 is not sufficient you need something
> newer...)

It should be. 2.0.8 is from r5746 which is new enough.
Comment 6 roger pack 2013-09-05 14:41:55 UTC
Yeah I was getting the same error message with 2.0.8 and pinged them about it.  Apparently the crt they bundled with 2.0.8 wasn't new enough or something like that, and they plan on releasing a new release soon...from what I could glean that is.
Comment 7 Jonathan Wakely 2013-09-05 15:53:58 UTC
Ah I see. Thanks for the info.