Bug 55336 - Feature request : message output format XML
Summary: Feature request : message output format XML
Status: RESOLVED DUPLICATE of bug 19165
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: unknown
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-15 08:05 UTC by Clemens
Modified: 2012-11-15 10:39 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens 2012-11-15 08:05:28 UTC
Every compiler has its own error output format. It would be better for IDE's if all would have the same error message output syntax.

Benefits:
- easier parsing for all developmetn environments
- compount errors can be handelt together like

Exanmple:

<error index=0 id=W0004711>   !# index starting from zero
  <text file=myfile.cpp line=12345>wrong number of arguments in function xyz</text>
  <text file=myfile2 line=54321>error occurs at this position</text>
</error>

In this example you can see how it is possible to connect errors together.
Comment 1 Andrew Pinski 2012-11-15 08:08:31 UTC
I doubt this will be implemented.  The format for GCC's warning and errors are simple to parse as of right now.  In fact GCC will never have an id to the warning/error message.
Comment 2 Clemens 2012-11-15 08:24:41 UTC
(In reply to comment #1)
> I doubt this will be implemented.  The format for GCC's warning and errors are
> simple to parse as of right now.  In fact GCC will never have an id to the
> warning/error message.

The idea is not to make parsing more simple, just make parsing common to *all* compiler.

The second idea is that error messages could be connected together. This is right now only possible of parser know the semantic of an msg. It can no be determined from message format itself.
Comment 3 Manuel López-Ibáñez 2012-11-15 10:39:35 UTC
Hi Clemens,

What IDE? I already implemented a prototype patch for this in PR 19165, and there was zero interest from any IDE people. I honestly believe that if you don't have interested people with the access and the time to integrate this into a major IDE (Eclipse, Kdevelop, Emacs), then it will be a wasted effort.

In any case, nobody currently working on GCC has the time or the interest to work on such a feature, so you would need to start contributing to GCC or hire someone to implement it.

*** This bug has been marked as a duplicate of bug 19165 ***