User account creation filtered due to spam.

Bug 5516 - GCC warns on i^=j^=i^=j
Summary: GCC warns on i^=j^=i^=j
Status: RESOLVED DUPLICATE of bug 11751
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-01-28 11:26 UTC by smartmouse714
Modified: 2005-04-20 02:58 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
main.i.gz (1.88 KB, application/x-gzip )
2003-05-21 15:16 UTC, smartmouse714
Details

Note You need to log in before you can comment on or make changes to this bug.
Description smartmouse714 2002-01-28 11:26:01 UTC
The symmetric bit operation is legal in ANSI C but GCC warns "undefined operation".

Release:
2.95.X & 3.0.X

Environment:
cygwin
Comment 1 Nathan Sidwell 2002-01-28 15:35:42 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Not a bug, that is not legal, and invokes undefined effects.
    lookup sequence point in the standard
Comment 2 Andrew Pinski 2005-04-20 02:58:35 UTC
Reopening to ....
Comment 3 Andrew Pinski 2005-04-20 02:58:53 UTC
Mark as a dup of bug 11751.

*** This bug has been marked as a duplicate of 11751 ***