Bug 55129 - removal of gcc-core tarballs leads to huge extraction times
Summary: removal of gcc-core tarballs leads to huge extraction times
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: regression (show other bugs)
Version: 4.7.0
: P3 major
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-29 21:09 UTC by Roger Meyer
Modified: 2016-08-14 00:13 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Meyer 2012-10-29 21:09:07 UTC
now that gcc-core and all other tarballs are merged into a single, huge 83 MB bzip2 tarball, i waste serious time whenever i rebuild my linux distro in qemu.

unpacking the official .bz2 tarball on qemu/mips takes nearly 2 hours (!)

since it is unlikely that i could convince you to go back to the former distribution strategy, i suggest shipping the tarballs additionally in .xz format, which is 3-4 times faster to extract.

i compared speeds of the official gcc 4.7.0 bzip2 tarballs vs a .xz version i made out of the former.

/dev/shm $ cp ~/Downloads/gcc-4.7.2.tar.bz2 .
/dev/shm $ time tar xf gcc-4.7.2.tar.bz2 

real    0m19.381s
user    0m18.866s
sys     0m2.616s
/dev/shm $ tar cJf gcc-4.7.2.tar.xz gcc-4.7.2
/dev/shm $ la gcc-4.7.2.tar.xz
-rw-r--r-- 1 roger users 66696632 Oct 29 21:50 gcc-4.7.2.tar.xz
/dev/shm $ la gcc-4.7.2.tar.bz2 
-rw-r--r-- 1 roger users 82884636 Oct 29 21:44 gcc-4.7.2.tar.bz2
/dev/shm $ rm -rf gcc-4.7.2
/dev/shm $ time tar xf gcc-4.7.2.tar.xz 

real    0m7.410s
user    0m7.225s
sys     0m1.695s

even on this high-end 3.1Ghz system the .xz version is 3 times faster.


since the tarball is also a good bit smaller (66 vs 82 MB, could be further reduced by using higher compression options), i strongly suggest adding .xz to the official releases, to accommodate for the heavily increased tarball sizes.
Comment 1 Roger Meyer 2012-10-29 21:19:32 UTC
before you suggest using the .tar.gz instead:
that one is 100 MB and increases download times and needed storage space significantly.

.xz is the best of both world, fast extraction speeds and small tarballs.
Comment 2 Manuel López-Ibáñez 2012-10-29 21:56:01 UTC
(In reply to comment #1)
> before you suggest using the .tar.gz instead:
> that one is 100 MB and increases download times and needed storage space
> significantly.
> 
> .xz is the best of both world, fast extraction speeds and small tarballs.

I think this has been suggested already, and the people in charge were not opposed to the idea. But... someone needs to step up, and offer themselves to update all the relevant scripts. Best place to offer your help is gcc@gcc.gnu.org (use a clear subject line, so the people in charge will actually read your email).
Comment 3 Andrew Pinski 2016-08-14 00:13:59 UTC
>huge 83 MB bzip2 

83MB is not huge in any sense.