Bug 54840 - ieee_arithmetic intrinsic module
Summary: ieee_arithmetic intrinsic module
Status: RESOLVED DUPLICATE of bug 29383
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: unknown
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-06 22:58 UTC by Andy Nelson
Modified: 2012-10-07 00:08 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Nelson 2012-10-06 22:58:21 UTC
I guess this isn't actually a bug, but an rfe, or something similarly named. Don't know the right place for putting this into the record, so I'm putting it
into bugzilla in hopes of having it somewhere.

It would be a very nice thing to have available the ieee_arithmetic intrinsic
module, which afaik, does not exist in gfortran yet (see below), at least as of 4.7.0. Probably, for some compiler newbie, it would be a fairly easy task to implement it. (not me unfortunately...round tuit shortages are a fact of life in my universe).

In particular the functionality that does things like ieee_is_nan(x) and its
friends would be what I was after most specifically.

Thanks,

Andy Nelson





 gfortran define_kind.f90 
define_kind.f90:17.4:

use ieee_arithmetic
    1
Fatal Error: Can't open module file 'ieee_arithmetic.mod' for reading at (1): No such file or directory
115 ml-fey : gfortran -v
Using built-in specs.
COLLECT_GCC=gfortran
COLLECT_LTO_WRAPPER=/usr/aprojects/hpcsoft/moonlight/gcc/4.7.0/bin/../libexec/gcc/x86_64-unknown-linux-gnu/4.7.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc-4.7.0/configure --prefix=/usr/projects/hpcsoft/moonlight/gcc/4.7.0 --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,fortran --disable-libgcj --disable-multilib --with-gmp=/tmp/dog/gmp-5.0.4 --with-mpfr=/tmp/dog/mpfr-3.1.0 --with-mpc=/tmp/dog/mpc-0.9 --with-ppl=/tmp/dog/ppl-0.12 --with-cloog=/tmp/dog/cloog-parma-0.16.1 --enable-cloog-backend=ppl --with-host-libstdcxx='-L/tmp/dog/gcc/lib64 -lstdc++ -lsupc++ -lm'
Thread model: posix
gcc version 4.7.0 (GCC) 


...gives similar errors for various other spellings like:

120 ml-fey : !gfo
gfortran define_kind.f90
define_kind.f90:17.17:

use, intrinsic :: ieee_arithmetic
                 1
Fatal Error: Can't find an intrinsic module named 'ieee_arithmetic' at (1)
Comment 1 kargl 2012-10-07 00:08:49 UTC
> Probably, for some compiler newbie, it would be a fairly easy task to
> implement it.

It much much much harder to implement than you think.

*** This bug has been marked as a duplicate of bug 29383 ***