Bug 53203 - [5/6/7 Regression]: gcc.dg/setjmp-1.c
Summary: [5/6/7 Regression]: gcc.dg/setjmp-1.c
Status: RESOLVED WORKSFORME
Alias: None
Product: gcc
Classification: Unclassified
Component: regression (show other bugs)
Version: 4.8.0
: P4 normal
Target Milestone: 5.5
Assignee: Not yet assigned to anyone
URL:
Keywords: diagnostic
Depends on: 53176
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 21:42 UTC by Hans-Peter Nilsson
Modified: 2017-01-17 01:37 UTC (History)
2 users (show)

See Also:
Host: x86_64-unknown-linux-gnu
Target: cris-axis-elf
Build:
Known to work:
Known to fail:
Last reconfirmed: 2012-07-13 00:00:00


Attachments
repeat with "cc1 -fpreprocessed setjmp-1.i -quiet -O -Wclobbered -Wextra -Wall -fno-diagnostics-show-caret" (468 bytes, text/plain)
2012-05-02 21:42 UTC, Hans-Peter Nilsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Nilsson 2012-05-02 21:42:29 UTC
Created attachment 27292 [details]
repeat with "cc1 -fpreprocessed setjmp-1.i -quiet -O -Wclobbered -Wextra -Wall -fno-diagnostics-show-caret"

This test previously passed, now it fails.
A patch in the revision range (last_known_working:first_known_failing) 187015:187022
exposed or caused this regression.  Since then it fails as follows:

Running /tmp/hpautotest-gcc0/gcc/gcc/testsuite/gcc.dg/dg.exp ...
...
FAIL: gcc.dg/setjmp-1.c spurious clobbered warning (test for bogus messages, line 16)

Lines in gcc.log:
/tmp/hpautotest-gcc0/gcc/gcc/testsuite/gcc.dg/setjmp-1.c: In function 'compare_float':
/tmp/hpautotest-gcc0/gcc/gcc/testsuite/gcc.dg/setjmp-1.c:16:23: warning: argument 'a' might be clobbered by 'longjmp' or 'vfork' [-Wclobbered]
/tmp/hpautotest-gcc0/gcc/gcc/testsuite/gcc.dg/setjmp-1.c:16:33: warning: argument 'b' might be clobbered by 'longjmp' or 'vfork' [-Wclobbered]

Author of suspect patch in revision range CC:ed.

Preprocessed setjmp-1.i attached; the regression might be related to the actual target-specific setjmp implementation (though simple and non-surprising, non-inline).
Comment 1 Hans-Peter Nilsson 2012-07-13 08:13:14 UTC
This seems connected to PR53176 but the reasons aren't obvious.  Now that PR53176 is fixed, this went (back) into hiding; the test now passes.  I think there's a deeper issue so I'm just suspending this PR, not resolving as fixed.
Comment 2 Jakub Jelinek 2013-03-22 14:44:17 UTC
GCC 4.8.0 is being released, adjusting target milestone.
Comment 3 Jakub Jelinek 2013-05-31 10:58:27 UTC
GCC 4.8.1 has been released.
Comment 4 Jakub Jelinek 2013-10-16 09:50:22 UTC
GCC 4.8.2 has been released.
Comment 5 Richard Biener 2014-05-22 09:03:50 UTC
GCC 4.8.3 is being released, adjusting target milestone.
Comment 6 Jakub Jelinek 2014-12-19 13:29:45 UTC
GCC 4.8.4 has been released.
Comment 7 Richard Biener 2015-06-23 08:18:41 UTC
The gcc-4_8-branch is being closed, re-targeting regressions to 4.9.3.
Comment 8 Jakub Jelinek 2015-06-26 19:54:51 UTC
GCC 4.9.3 has been released.
Comment 9 Richard Biener 2016-08-03 10:55:19 UTC
GCC 4.9 branch is being closed
Comment 10 Aldy Hernandez 2017-01-16 11:14:57 UTC
Cannot reproduce.  Can we close this?
Comment 11 Hans-Peter Nilsson 2017-01-17 01:37:15 UTC
I guess it's of no use keeping this PR open if it
- gets on people's radars just for being open
- is hidden since long (with no known reproducer)
- has been out of the reporter's mind for at least four years
- triggers the reporter to sheepishly list at least three reasons to close it
Thus closed.  I guess WORKSFORME fits best.