Bug 53043 - [4.8 Regression] gcc.target/i386/pr45830.c scan-tree-dump switchconv "Expanding as bit test is preferable"
Summary: [4.8 Regression] gcc.target/i386/pr45830.c scan-tree-dump switchconv "Expandi...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.8.0
: P3 normal
Target Milestone: ---
Assignee: Steven Bosscher
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-19 14:29 UTC by H.J. Lu
Modified: 2012-04-19 15:14 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2012-04-19 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2012-04-19 14:29:43 UTC
On Linux/x86, revision 186576 gave

FAIL: gcc.target/i386/pr45830.c scan-tree-dump switchconv "Expanding as bit test is preferable"

Revision 186572 is OK.
Comment 1 H.J. Lu 2012-04-19 14:55:54 UTC
It may be caused by revision 186576:

http://gcc.gnu.org/ml/gcc-cvs/2012-04/msg00527.html
Comment 2 Steven Bosscher 2012-04-19 15:09:29 UTC
Mine. The message was updated in my local tree but I omitted that file in the commit.