Bug 52852 - [C++11] The preprocessor fails to parse multi-line c++0x/c++11 raw strings.
Summary: [C++11] The preprocessor fails to parse multi-line c++0x/c++11 raw strings.
Status: RESOLVED DUPLICATE of bug 57824
Alias: None
Product: gcc
Classification: Unclassified
Component: preprocessor (show other bugs)
Version: 4.6.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: rejects-valid
: 53165 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-03 19:10 UTC by Bauke Conijn
Modified: 2013-08-13 17:03 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2012-04-03 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bauke Conijn 2012-04-03 19:10:32 UTC
When compiling the following piece of code, using "g++ -v -save-temps a.cpp -std=c++0x", the preprocessor fails to parse it correctly. This causes the compilation to fail.

#include <cstdio>
#define log(a) printf("%s\n", a)
int main() {
        log(R"delimiter(
                Multi
                line
                raw
                string
        )delimiter");
}

The -save-temps output is attached.
Comment 1 Jonathan Wakely 2012-04-30 10:12:54 UTC
*** Bug 53165 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2013-08-13 15:49:03 UTC
Dup.

*** This bug has been marked as a duplicate of bug 57620 ***
Comment 3 Jakub Jelinek 2013-08-13 17:03:34 UTC

*** This bug has been marked as a duplicate of bug 57824 ***