Bug 52482 - libitm INVALID MNEMONIC in .S (powerpc asm)
Summary: libitm INVALID MNEMONIC in .S (powerpc asm)
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libitm (show other bugs)
Version: 4.7.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-04 17:43 UTC by David Fang
Modified: 2015-07-03 17:42 UTC (History)
4 users (show)

See Also:
Host: powerpc-apple-darwin8
Target: powerpc-apple-darwin8
Build: powerpc-apple-darwin8
Known to work: 4.9.4, 5.1.1, 6.0
Known to fail: 4.7.0
Last reconfirmed:


Attachments
RC1 entire build log (540.31 KB, application/x-bzip2)
2012-03-04 17:43 UTC, David Fang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Fang 2012-03-04 17:43:22 UTC
Created attachment 26823 [details]
RC1 entire build log

On powerpc-darwin8, with:
fang% gcc -v
Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /var/tmp/gcc/gcc-5370~2/src/configure --disable-checking -enable-werror --prefix=/usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/lib --build=powerpc-apple-darwin8 --host=powerpc-apple-darwin8 --target=powerpc-apple-darwin8
Thread model: posix
gcc version 4.0.1 (Apple Computer, Inc. build 5370)

h/w: dual 533 MHz G4
OS: 10.4.11

Using Jack Howarth's fink packaging for gcc-4.7.0-RC-20120302, slightly adapted for darwin8:

configure:
../gcc-4.7.0-RC-20120302/configure --prefix=/sw --prefix=/sw/lib/gcc4.7 --mand
ir=/sw/share/man --infodir=/sw/lib/gcc4.7/info --enable-languages=c,c++,fortran,
lto,objc,obj-c++,java --with-gmp=/sw --with-libiconv-prefix=/sw --with-ppl=/sw -
-with-cloog=/sw --with-mpc=/sw --with-system-zlib --x-includes=/usr/X11R6/includ
e --x-libraries=/usr/X11R6/lib --program-suffix=-fsf-4.7 --enable-cloog-backend=
isl --with-dwarf2 --disable-libjava-multilib --disable-libquadmath


gcc-4.7.0-RC1 (20120302) makes it all the way through stage 3 bootstrap comparison, and then during libitm:

/bin/sh ./libtool   --mode=compile /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/
darwin_objdir/./gcc/xgcc -B/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_o
bjdir/./gcc/ -B/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/bin/ -B/sw/lib/gcc4.7/p
owerpc-apple-darwin8.11.0/lib/ -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.
0/include -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include    -DHA
VE_CONFIG_H -I. -I../../../gcc-4.7.0-RC-20120302/libitm  -I../../../gcc-4.7.0-RC
-20120302/libitm/config/powerpc -I../../../gcc-4.7.0-RC-20120302/libitm/config/p
osix -I../../../gcc-4.7.0-RC-20120302/libitm/config/generic -I../../../gcc-4.7.0
-RC-20120302/libitm  -Wall -Werror  -Wc,-pthread -g -O2 -MT sjlj.lo -MD -MP -MF 
.deps/sjlj.Tpo -c -o sjlj.lo ../../../gcc-4.7.0-RC-20120302/libitm/config/powerp
c/sjlj.S
libtool: compile:  /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./
gcc/xgcc -B/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/ -B/
sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/bin/ -B/sw/lib/gcc4.7/powerpc-apple-dar
win8.11.0/lib/ -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include -isyst
em /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include -DHAVE_CONFIG_H -I. -I.
./../../gcc-4.7.0-RC-20120302/libitm -I../../../gcc-4.7.0-RC-20120302/libitm/con
fig/powerpc -I../../../gcc-4.7.0-RC-20120302/libitm/config/posix -I../../../gcc-
4.7.0-RC-20120302/libitm/config/generic -I../../../gcc-4.7.0-RC-20120302/libitm 
-Wall -pthread -Werror -g -O2 -MT sjlj.lo -MD -MP -MF .deps/sjlj.Tpo -c ../../..
/gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S  -fno-common -DPIC -o .libs/
sjlj.o
../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S:155:Invalid mnemonic
 'FUNC'
../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S:250:Invalid mnemonic
 'CALL'
../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S:259:Invalid mnemonic
 'END'
../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S:262:Invalid mnemonic
 'HIDDEN'
../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S:263:Invalid mnemonic
 'FUNC'
../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S:407:Invalid mnemonic
 'END'
make[4]: *** [sjlj.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-target-libitm] Error 2
make[1]: *** Waiting for unfinished jobs....

possibly continuation of PR 51031
Comment 1 David Fang 2012-03-04 18:45:58 UTC
powerpc/sjlj.S contains:

#include "asmcfi.h"

#if defined(__powerpc64__) && defined(__ELF__)
...
#elif defined(__ELF__)
...
#elif defined(_CALL_DARWIN)
.macro FUNC name
        .globl  _$0
_$0:
.endmacro
.macro END name
.endmacro
.macro HIDDEN name
        .private_extern _$0
.endmacro
.macro CALL name
        bl      _$0
.endmacro
# ifdef __ppc64__
        .machine ppc64
# else
        .machine ppc7400
# endif
#else
#error "unsupported system"
#endif

And I didn't see the "unsupported system" message, so maybe something's funky with the asm macro definitions under _CALL_DARWIN?  Is there a particular assembler or assembly-style that's assumed?

I have for /usr/bin/as:
Apple Computer, Inc. version cctools-622.9~2, GNU assembler version 1.38
Comment 2 David Fang 2012-03-05 21:02:27 UTC
I tried overriding as to point to odcctools-20090808's version:

% odas -v
Apple Inc version odcctools-698.1od9, GNU assembler version 1.38

and that worked better.

<hacked gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/as ORIGINAL_AS_FOR_TARGET>

% /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/xgcc -B/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/ -B/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/bin/ -B/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/lib/ -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include -DHAVE_CONFIG_H -I. -I../../../gcc-4.7.0-RC-20120302/libitm -I../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc -I../../../gcc-4.7.0-RC-20120302/libitm/config/posix -I../../../gcc-4.7.0-RC-20120302/libitm/config/generic -I../../../gcc-4.7.0-RC-20120302/libitm -Wall -pthread -Werror -g -O2 -MT sjlj.lo -MD -MP -MF .deps/sjlj.Tpo -c ../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S -fno-common -DPIC -v -o .libs/sjlj.o
Reading specs from /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/specs
COLLECT_GCC=/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/xgcc
Target: powerpc-apple-darwin8.11.0
Configured with: ../gcc-4.7.0-RC-20120302/configure --prefix=/sw --prefix=/sw/lib/gcc4.7 --mandir=/sw/share/man --infodir=/sw/lib/gcc4.7/info --enable-languages=c,c++,fortran,lto,objc,obj-c++,java --with-gmp=/sw --with-libiconv-prefix=/sw --with-ppl=/sw --with-cloog=/sw --with-mpc=/sw --with-system-zlib --x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib --program-suffix=-fsf-4.7 --enable-cloog-backend=isl --with-dwarf2 --disable-libjava-multilib --disable-libquadmath
Thread model: posix
gcc version 4.7.0 20120302 (prerelease) (GCC) 
COLLECT_GCC_OPTIONS='-mmacosx-version-min=10.4' '-B' '/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/' '-B' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/bin/' '-B' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/lib/' '-isystem' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include' '-isystem' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include' '-D' 'HAVE_CONFIG_H' '-I' '.' '-I' '../../../gcc-4.7.0-RC-20120302/libitm' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/posix' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/generic' '-I' '../../../gcc-4.7.0-RC-20120302/libitm' '-Wall' '-pthread' '-Werror' '-g' '-O2' '-MT' 'sjlj.lo' '-MD' '-MP' '-MF' '.deps/sjlj.Tpo' '-c' '-fno-common' '-D' 'PIC' '-v' '-o' '.libs/sjlj.o'
 /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/cc1 -E -lang-asm -quiet -v -I . -I ../../../gcc-4.7.0-RC-20120302/libitm -I ../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc -I ../../../gcc-4.7.0-RC-20120302/libitm/config/posix -I ../../../gcc-4.7.0-RC-20120302/libitm/config/generic -I ../../../gcc-4.7.0-RC-20120302/libitm -iprefix /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/ -isystem /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/include -isystem /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/include-fixed -MD .libs/sjlj.d -MF .deps/sjlj.Tpo -MP -MT sjlj.lo -D__DYNAMIC__ -D_REENTRANT -D HAVE_CONFIG_H -D PIC -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include -isystem /sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include ../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc/sjlj.S -feliminate-unused-debug-symbols -fPIC -mmacosx-version-min=10.4 -Wall -Werror -fno-common -g -fworking-directory -O2 -fno-directives-only -o /var/tmp//ccXtGHR0.s
ignoring nonexistent directory "/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include"
ignoring nonexistent directory "/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/include"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/include-fixed"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/../../../../powerpc-apple-darwin8.11.0/include"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/../../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/include"
ignoring nonexistent directory "/usr/local/include"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/../../include"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/../../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/include-fixed"
ignoring nonexistent directory "/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/gcc/../lib/gcc/../../lib/gcc/powerpc-apple-darwin8.11.0/4.7.0/../../../../powerpc-apple-darwin8.11.0/include"
ignoring duplicate directory "../../../gcc-4.7.0-RC-20120302/libitm"
#include "..." search starts here:
#include <...> search starts here:
 .
 ../../../gcc-4.7.0-RC-20120302/libitm
 ../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc
 ../../../gcc-4.7.0-RC-20120302/libitm/config/posix
 ../../../gcc-4.7.0-RC-20120302/libitm/config/generic
 /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/include
 /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/include-fixed
 /usr/include
 /System/Library/Frameworks
 /Library/Frameworks
End of search list.
COLLECT_GCC_OPTIONS='-mmacosx-version-min=10.4' '-B' '/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/' '-B' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/bin/' '-B' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/lib/' '-isystem' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include' '-isystem' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include' '-D' 'HAVE_CONFIG_H' '-I' '.' '-I' '../../../gcc-4.7.0-RC-20120302/libitm' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/posix' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/generic' '-I' '../../../gcc-4.7.0-RC-20120302/libitm' '-Wall' '-pthread' '-Werror' '-g' '-O2' '-MT' 'sjlj.lo' '-MD' '-MP' '-MF' '.deps/sjlj.Tpo' '-c' '-fno-common' '-D' 'PIC' '-v' '-o' '.libs/sjlj.o'
 /Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/as --gstabs -arch ppc -o .libs/sjlj.o /var/tmp//ccXtGHR0.s
COMPILER_PATH=/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/
LIBRARY_PATH=/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/:/usr/lib/
COLLECT_GCC_OPTIONS='-mmacosx-version-min=10.4' '-B' '/Volumes/Isolde/fink.build/gcc47-4.7.0-0.rc1/darwin_objdir/./gcc/' '-B' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/bin/' '-B' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/lib/' '-isystem' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/include' '-isystem' '/sw/lib/gcc4.7/powerpc-apple-darwin8.11.0/sys-include' '-D' 'HAVE_CONFIG_H' '-I' '.' '-I' '../../../gcc-4.7.0-RC-20120302/libitm' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/powerpc' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/posix' '-I' '../../../gcc-4.7.0-RC-20120302/libitm/config/generic' '-I' '../../../gcc-4.7.0-RC-20120302/libitm' '-Wall' '-pthread' '-Werror' '-g' '-O2' '-MT' 'sjlj.lo' '-MD' '-MP' '-MF' '.deps/sjlj.Tpo' '-c' '-fno-common' '-D' 'PIC' '-v' '-o' '.libs/sjlj.o'

Does this mean I need gcc47 to depend on the newer odcctools at run-time, as well as build-time?
Comment 3 David Fang 2012-03-08 16:03:46 UTC
This build finished, using odcctools' as, but there are some test failures with libitm.

http://gcc.gnu.org/ml/gcc-testresults/2012-03/msg00893.html

How can I get the failure details for libitm tests from the build dir?
Comment 4 David Fang 2012-03-09 20:44:14 UTC
Also, from my testing, it looks like AS=odas is needed; if I just pass AS_FOR_TARGET=odas, then the wrong assembler is used and sjlj.S fails.
Comment 5 David Fang 2012-03-12 02:28:49 UTC
Reran using entire set of odcctools-20090808 (passed through configure), looks like same failures:

http://gcc.gnu.org/ml/gcc-testresults/2012-03/msg01296.html
Comment 6 venture37 2014-06-20 11:49:06 UTC
Still the case with 4.7.3 on OS X 10.4.11 with XCode 2.5 (ToolSupport: 794.0)

libtool: compile:  /usr/pkgsrc/lang/gcc47/work/build/./gcc/xgcc -B/usr/pkgsrc/lang/gcc47/work/build/./gcc/ -B/usr/pkg/gcc47/powerpc-apple-darwin8/bin/ -B/usr/pkg/gcc47/powerpc-apple-darwin8/lib/ -isystem /usr/pkg/gcc47/powerpc-apple-darwin8/include -isystem /usr/pkg/gcc47/powerpc-apple-darwin8/sys-include -DHAVE_CONFIG_H -I. -I../../../gcc-4.7.3/libitm -I../../../gcc-4.7.3/libitm/config/powerpc -I../../../gcc-4.7.3/libitm/config/posix -I../../../gcc-4.7.3/libitm/config/generic -I../../../gcc-4.7.3/libitm -Wall -pthread -Werror -g -pipe -O2 -I/usr/pkg/include -I/usr/include -MT sjlj.lo -MD -MP -MF .deps/sjlj.Tpo -c ../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S  -fno-common -DPIC -o .libs/sjlj.o
yes
checking for getpid... ../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S:155:Invalid mnemonic 'FUNC'
../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S:250:Invalid mnemonic 'CALL'
../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S:259:Invalid mnemonic 'END'
../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S:262:Invalid mnemonic 'HIDDEN'
../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S:263:Invalid mnemonic 'FUNC'
../../../gcc-4.7.3/libitm/config/powerpc/sjlj.S:407:Invalid mnemonic 'END'
Makefile:496: recipe for target 'sjlj.lo' failed
gmake[4]: *** [sjlj.lo] Error 1
gmake[4]: Leaving directory '/usr/pkgsrc/lang/gcc47/work/build/powerpc-apple-darwin8/libitm'
Makefile:697: recipe for target 'all-recursive' failed
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory '/usr/pkgsrc/lang/gcc47/work/build/powerpc-apple-darwin8/libitm'
Makefile:360: recipe for target 'all' failed
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory '/usr/pkgsrc/lang/gcc47/work/build/powerpc-apple-darwin8/libitm'
Makefile:16339: recipe for target 'all-target-libitm' failed
gmake[1]: *** [all-target-libitm] Error 2
gmake[1]: *** Waiting for unfinished jobs....
Comment 7 venture37 2014-06-20 11:51:53 UTC
This is on 32bit PowerPC 7450 system 
Darwin 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc
Comment 8 torvald 2015-01-23 12:17:01 UTC
Can somebody with access to a powerpc-apple-darwin8 check whether this bug is still present in SVN trunk?  Thanks!
Comment 9 venture37 2015-01-23 17:34:22 UTC
(In reply to torvald from comment #8)
> Can somebody with access to a powerpc-apple-darwin8 check whether this bug
> is still present in SVN trunk?  Thanks!

Sure thing.
Comment 10 venture37 2015-01-24 20:59:10 UTC
G4 with a 32bit ppc7450 CPU, running OS X Tiger 10.4.11 with Xcode 2.5 (GCC 4.0.1)
Cloned git repo & configured source 

Configured it with the following flags (taken from config.log)
./configure --enable-languages=c --enable-shared --enable-long-long --with-local-prefix=/Users/myusr/SandBox/gcc-trunk --enable-libssp --enable-threads=posix STRIP_FOR_TARGET=/usr/bin/strip --with-dwarf2 --disable-libitm --disable-nls --with-gmp=/Users/myusr/pkg --with-mpc=/Users/myusr/pkg --with-mpfr=/Users/myusr/pkg --with-os-directory=darwin --with-arch-directory=powerpc --with-system-zlib --enable-__cxa_atexit --with-gxx-include-dir=/Users/myusr/pkg/gcc49/include/c++/ --prefix=/Users/myusr/SandBox/gcc-trunk --build=powerpc-apple-darwin8 --host=powerpc-apple-darwin8 --infodir=/Users/myusr/SandBox/gcc-trunk/info --mandir=/Users/myusr/SandBox/gcc-trunk/man

System had dependencies installed for GCC 4.9 installed via pkgsrc.

Ran make
Build fails at
echo timestamp > s-genrtl-h
/Users/myusr/Sandbox/gcc/host-powerpc-apple-darwin8/prev-gcc/xg++ -B/Users/myusr/Sandbox/gcc/host-powerpc-apple-darwin8/prev-gcc/ -B/Users/myusr/SandBox/gcc-trunk/powerpc-apple-darwin8/bin/ -nostdinc++ -B/Users/myusr/Sandbox/gcc/prev-powerpc-apple-darwin8/libstdc++-v3/src/.libs -B/Users/myusr/Sandbox/gcc/prev-powerpc-apple-darwin8/libstdc++-v3/libsupc++/.libs  -I/Users/myusr/Sandbox/gcc/prev-powerpc-apple-darwin8/libstdc++-v3/include/powerpc-apple-darwin8  -I/Users/myusr/Sandbox/gcc/prev-powerpc-apple-darwin8/libstdc++-v3/include  -I/Users/myusr/Sandbox/gcc/libstdc++-v3/libsupc++ -L/Users/myusr/Sandbox/gcc/prev-powerpc-apple-darwin8/libstdc++-v3/src/.libs -L/Users/myusr/Sandbox/gcc/prev-powerpc-apple-darwin8/libstdc++-v3/libsupc++/.libs -c   -g -O2 -mdynamic-no-pic -gtoggle -DIN_GCC    -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Werror -fno-common  -DHAVE_CONFIG_H -DGENERATOR_FILE -I. -Ibuild -I../.././gcc -I../.././gcc/build -I../.././gcc/../include  -I../.././gcc/../libcpp/include  \
        -o build/rtl.o ../.././gcc/rtl.c
../.././gcc/rtl.c: In function 'void cwi_output_hex(FILE*, const_rtx)':
../.././gcc/rtl.c:240:62: error: ISO C++98 does not support the 'q' gnu_printf length modifier [-Werror=format=]
   fprintf (outfile, HOST_WIDE_INT_PRINT_HEX, CWI_ELT (x, --i));
                                                              ^
../.././gcc/rtl.c:242:69: error: ISO C++98 does not support the 'q' gnu_printf length modifier [-Werror=format=]
     fprintf (outfile, HOST_WIDE_INT_PRINT_PADDED_HEX, CWI_ELT (x, i));
                                                                     ^
cc1plus: all warnings being treated as errors
make[3]: *** [build/rtl.o] Error 1

Also noticed that the compiler flags default to -m64 which won't work on a 32bit PowerPC host.
Comment 11 torvald 2015-01-26 13:00:20 UTC
Thanks for confirming.  However, that fails before libitm, for which you should file a separate bug report.  Thanks.
Comment 12 csanchezdll 2015-07-03 11:10:03 UTC
Seems to be still in SVN trunk. I have identified the problem and sent a patch:

https://gcc.gnu.org/ml/gcc-patches/2015-07/msg00191.html

Using newer cctools also solved the problem as newer gas versions support named parameters in macros, but with this patch updating cctools is not required.
Comment 13 mrs@gcc.gnu.org 2015-07-03 17:29:14 UTC
Author: mrs
Date: Fri Jul  3 17:28:43 2015
New Revision: 225388

URL: https://gcc.gnu.org/viewcvs?rev=225388&root=gcc&view=rev
Log:
2015-07-03  Carlos Sánchez de La Lama  <csanchezdll@gmail.com>

	PR target/52482
	* config/powerpc/sjlj.S: Port to Xcode 2.5.

Modified:
    trunk/libitm/ChangeLog
    trunk/libitm/config/powerpc/sjlj.S
Comment 14 mrs@gcc.gnu.org 2015-07-03 17:31:52 UTC
Author: mrs
Date: Fri Jul  3 17:31:21 2015
New Revision: 225389

URL: https://gcc.gnu.org/viewcvs?rev=225389&root=gcc&view=rev
Log:
2015-07-03  Carlos Sánchez de La Lama  <csanchezdll@gmail.com>

	PR target/52482
	* config/powerpc/sjlj.S: Port to Xcode 2.5.

Modified:
    branches/gcc-5-branch/libitm/ChangeLog
    branches/gcc-5-branch/libitm/config/powerpc/sjlj.S
Comment 15 mrs@gcc.gnu.org 2015-07-03 17:36:09 UTC
Author: mrs
Date: Fri Jul  3 17:35:37 2015
New Revision: 225390

URL: https://gcc.gnu.org/viewcvs?rev=225390&root=gcc&view=rev
Log:
2015-07-03  Carlos Sánchez de La Lama  <csanchezdll@gmail.com>

	PR target/52482
	* config/powerpc/sjlj.S: Port to Xcode 2.5.

Modified:
    branches/gcc-4_9-branch/libitm/ChangeLog
    branches/gcc-4_9-branch/libitm/config/powerpc/sjlj.S
Comment 16 mrs@gcc.gnu.org 2015-07-03 17:41:18 UTC
Fixed.
Fixed in all open release branches.
Comment 17 mrs@gcc.gnu.org 2015-07-03 17:42:42 UTC
Fink's 4.7 has to be patched by itself, if you would like the fix there.