User account creation filtered due to spam.

Bug 52061 - compiler internal error in extract_insn
Summary: compiler internal error in extract_insn
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.6.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-30 22:44 UTC by Juan Jose Garcia-Ripoll
Modified: 2013-09-10 10:37 UTC (History)
2 users (show)

See Also:
Host:
Target: mingw32
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Preprocessed C file (reproduces the bug) (130.29 KB, application/octet-stream)
2012-01-30 22:44 UTC, Juan Jose Garcia-Ripoll
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Jose Garcia-Ripoll 2012-01-30 22:44:17 UTC
Created attachment 26523 [details]
Preprocessed C file (reproduces the bug)

When building ECL on a recent version of mingw32, with gcc 4.6.1, I systematically get compiler internal errors in different functions with different code. Sometimes it is "volatile", sometimes other changes in the function fix it, but the problem seems always to be a relative displacement from an array of structures (cl_symbols). I attach preprocessed file which is enough to reproduce the bug -- I could not strip them down because of the large amount of needed types in this library

The output in mingw

$ gcc -g -O2 -w -c cmpname.i -o cmpname.o

cmpname.c: En la función 'L13init_function_name':
cmpname.c:482:1: error: no se reconoce la insn:
(insn 62 61 63 11 (set (mem/s/v/f/c:SI (plus:SI (reg/f:SI 54 virtual-stack-vars)
                (const_int -8 [0xfffffff8])) [4 lex0+0 S4 A32])
        (const:SI (plus:SI (symbol_ref:SI ("cl_symbols") [flags 0x440] <var_decl 046a5c60 cl_symbols>)
                (const_int 35700 [0x8b74])))) cmpname.c:457 -1
     (nil))
cmpname.c:482:1: error interno del compilador: en extract_insn, en recog.c:2109
Por favor envíe un reporte completo de bichos,
con el código preprocesado si es apropiado.
Vea <http://gcc.gnu.org/bugs.html> para más instrucciones.
Comment 1 Jean-Pierre Flori 2012-12-21 10:32:10 UTC
I can confirm this also happens on the current Cygwin distribution with GCC 4.6.3 bootstrapped with the Cygwin GCC 4.5.3 distributed in the gcc4 package.

I'm trying to build GCC 4.7.2 to see whether the bug is still present there.
Comment 2 Jean-Pierre Flori 2013-01-03 22:50:50 UTC
This is fixed with FSF GCC 4.7.2.
Comment 3 Kai Tietz 2013-09-10 10:37:04 UTC
Due this issue is in 4.6 tree, which isn't any longer under maintenance by gcc's team, I close this bug as won't fix.