User account creation filtered due to spam.

Bug 51736 - generic fortran procedures with allocatable/pointer argument
Summary: generic fortran procedures with allocatable/pointer argument
Status: RESOLVED DUPLICATE of bug 45521
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.6.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-02 19:06 UTC by Mianzhi Wang
Modified: 2012-01-02 22:38 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
a reduced example (222 bytes, text/x-fortran)
2012-01-02 19:06 UTC, Mianzhi Wang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mianzhi Wang 2012-01-02 19:06:24 UTC
Created attachment 26221 [details]
a reduced example

According to the f2008 standard (12.4.3.4.5), dummy arguments having allocatable attribute and pointer attribute should be distinguishable. Thus the attached reduced code should be valid.
Will this feature be included in the later releases? Or could anyone provide suggestions to work around? Thank you very much for your help and the great compiler.
Comment 1 Tobias Burnus 2012-01-02 22:38:29 UTC
(In reply to comment #0)
> Will this feature be included in the later releases?

Yes, it is definitely planed to support this feature, but it has not been implemented so far and won't be in GCC 4.7.0 (to be released in March?) It might get implemented for 4.8.

*** This bug has been marked as a duplicate of bug 45521 ***