Bug 50868 - [4.7 Regression] 1x176.gcc in SPEC CPU 2000 failed to build with LTO
Summary: [4.7 Regression] 1x176.gcc in SPEC CPU 2000 failed to build with LTO
Status: RESOLVED DUPLICATE of bug 50823
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.7.0
: P1 normal
Target Milestone: 4.7.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-25 15:48 UTC by H.J. Lu
Modified: 2011-12-05 19:30 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2011-10-25 15:48:10 UTC
On Linux/x86, revision 180302 failed to build 1x176.gcc in SPEC CPU 2000
with LTO:

gcc -O3 -funroll-loops -ffast-math -fwhole-program -flto=jobserver -fuse-linker-plugin  c-parse.o c-lang.o c-lex.o c-pragma.o c-decl.o c-typeck.o c-convert.o c-aux-info.o c-common.o c-iterate.o toplev.o version.o tree.o print-tree.o stor-layout.o fold-const.o function.o stmt.o expr.o calls.o expmed.o explow.o optabs.o varasm.o rtl.o print-rtl.o rtlanal.o emit-rtl.o real.o dbxout.o sdbout.o dwarfout.o xcoffout.o integrate.o jump.o cse.o loop.o unroll.o flow.o stupid.o combine.o regclass.o local-alloc.o global.o reload.o reload1.o caller-save.o insn-peep.o reorg.o sched.o final.o recog.o reg-stack.o insn-opinit.o insn-recog.o insn-extract.o insn-output.o insn-emit.o insn-attrtab.o m88k.o getpwd.o convert.o bc-emit.o bc-optab.o obstack.o   -lm  -o cc1
..
lto1: internal compiler error: in inline_small_functions, at ipa-inline.c:1413
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
lto-wrapper: gcc returned 1 exit status
/usr/local/bin/ld: lto-wrapper failed
collect2: error: ld returned 1 exit status

Revision 180168 is OK. It may be caused by revision 180247:

http://gcc.gnu.org/ml/gcc-cvs/2011-10/msg00843.html

and revision 180249:

http://gcc.gnu.org/ml/gcc-cvs/2011-10/msg00845.html

doesn't fix it.
Comment 1 Markus Trippelsdorf 2011-10-25 16:12:12 UTC
Dup of Bug 50823
Comment 2 Richard Biener 2011-10-27 11:45:55 UTC
Confirmed with -Ofast -funroll-loops -fpeel-loops -march=native on x86_64
sandy-bridge (but not with -O3 -ffast-math -flto=2 -fno-fat-lto-objects -fuse-linker-plugin -fipa-pta).

But yes, probably a dup.

*** This bug has been marked as a duplicate of bug 50823 ***