Bug 50104 - internal compiler error: in extract_insn
Summary: internal compiler error: in extract_insn
Status: RESOLVED DUPLICATE of bug 50099
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.6.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-17 05:05 UTC by Khem Raj
Modified: 2011-08-17 08:12 UTC (History)
1 user (show)

See Also:
Host: x86_64-linux
Target: arm-eabi
Build: x86_64-linux
Known to work: 4.5.1, 4.5.2
Known to fail: 4.6.0, 4.6.1, 4.7.0
Last reconfirmed:


Attachments
testcase (16.52 KB, application/octet-stream)
2011-08-17 05:05 UTC, Khem Raj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Khem Raj 2011-08-17 05:05:11 UTC
Created attachment 25027 [details]
testcase

gcc 4.6 branch and trunk have this ICE happening on ARM when attached test case is compiled with -march=armv7-a -O2. It works ok with gcc 4.5

here is error

vfprintf.c: In function ‘ust_safe_vfprintf’:
vfprintf.c:956:1: error: unrecognizable insn:
(insn 3644 3643 3645 145 (set (subreg:SI (reg/v:DI 160 [ _umax ]) 0)
        (sign_extend:SI (mem:QI (plus:SI (mult:SI (reg/v:SI 166 [ nextarg ])
                        (const_int 8 [0x8]))
                    (reg/f:SI 1405 [ argtable.7 ])) [4 *D.5277_569+0 S1 A32]))) vfprintf.c:555 -1
     (nil))
vfprintf.c:956:1: internal compiler error: in extract_insn, at recog.c:2127


I have traced it to a regression after the patch for bug 43137 was committed to trunk.

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43137
Comment 1 Mikael Pettersson 2011-08-17 07:52:49 UTC
Duplicate of PR50099.
Comment 2 Richard Biener 2011-08-17 08:12:50 UTC
.

*** This bug has been marked as a duplicate of bug 50099 ***