Bug 50048 - "cc1: note: obsolete option -I- used, please use -iquote instead" during bootstrap
Summary: "cc1: note: obsolete option -I- used, please use -iquote instead" during boot...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: ada (show other bugs)
Version: 4.6.1
: P3 minor
Target Milestone: 6.0
Assignee: Eric Botcazou
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-11 18:55 UTC by Ludovic Brenta
Modified: 2015-12-06 18:46 UTC (History)
2 users (show)

See Also:
Host: i386-linux-gnu
Target: i386-linux-gnu
Build: i386-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2015-12-06 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic Brenta 2011-08-11 18:55:44 UTC
During bootstrapping with ada enabled, I get this message multiple times:

cc1: note: obsolete option -I- used, please use -iquote instead

because of line 250 in gcc/ada/gcc-interface/Makefile.in.

Recent changes in the glibc header files have caused GCC to fail to bootstrap on i386; see http://bugs.debian.org/637418.  Replacing -I- with -iquote as suggested fixes this.
Comment 1 nightstrike 2012-06-21 19:16:14 UTC
This is still a problem for 4.8.0.  Offending lines are around line 270:


# Specify the directories to be searched for header files.
# Both . and srcdir are used, in that order,
# so that tm.h and config.h will be found in the compilation
# subdirectory rather than in the source directory.
INCLUDES = -I- -I. -I.. -I$(srcdir)/ada -I$(srcdir) -I$(srcdir)/../include

ADA_INCLUDES = -I- -I. -I$(srcdir)/ada
Comment 2 Eric Botcazou 2015-12-06 14:14:06 UTC
Still present on mainline.
Comment 3 Eric Botcazou 2015-12-06 14:14:27 UTC
Fixing.
Comment 4 Eric Botcazou 2015-12-06 18:45:28 UTC
Author: ebotcazou
Date: Sun Dec  6 18:44:56 2015
New Revision: 231341

URL: https://gcc.gnu.org/viewcvs?rev=231341&root=gcc&view=rev
Log:
gnattools/
	PR ada/50048
	* Makefile.in (ftop_srcdir): New variable.
	(INCLUDES_FOR_SUBDIR): Use -iquote and $(ftop_srcdir).
gcc/ada/
	PR ada/50048
	* gcc-interface/Makefile.in (INCLUDES): Use -iquote.

Modified:
    trunk/gcc/ada/ChangeLog
    trunk/gcc/ada/gcc-interface/Makefile.in
    trunk/gnattools/ChangeLog
    trunk/gnattools/Makefile.in
Comment 5 Eric Botcazou 2015-12-06 18:46:02 UTC
.