Bug 49879 - [h8300] ICE in maybe_record_trace_start, at dwarf2cfi.c:2439
Summary: [h8300] ICE in maybe_record_trace_start, at dwarf2cfi.c:2439
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.7.0
: P3 normal
Target Milestone: 4.7.0
Assignee: Richard Henderson
URL:
Keywords:
Depends on: 49864
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-27 18:47 UTC by Arnaud Lacombe
Modified: 2011-08-02 22:20 UTC (History)
1 user (show)

See Also:
Host:
Target: h8300-elf
Build:
Known to work:
Known to fail:
Last reconfirmed: 2011-07-28 16:20:58


Attachments
non-reduced testcase (121.81 KB, text/plain)
2011-07-28 01:22 UTC, Arnaud Lacombe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Lacombe 2011-07-27 18:47:29 UTC
from: 

Using built-in specs.                                                           
COLLECT_GCC=/src/h8300/obj/destdir/bin/h8300-elf-gcc
COLLECT_LTO_WRAPPER=/src/h8300/obj/destdir/libexec/gcc/h8300-elf/4.7.0/lto-wrapper
Target: h8300-elf
Configured with: ../../../external/gpl/gcc/configure
--prefix=/src/h8300/obj/destdir --target=h8300-elf --enable-languages=c
Thread model: single
gcc version 4.7.0 20110726 (experimental) (GCC)


/src/linux/linux/block/elevator.c: In function '__elv_add_request':
/src/linux/linux/block/elevator.c:729:1: internal compiler error: in maybe_record_trace_start, at dwarf2cfi.c:2439
Please submit a full bug report, 
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

might be related to BUG 49874 and BUG 49878
Comment 1 Arnaud Lacombe 2011-07-27 18:47:41 UTC
testcase to come
Comment 2 Arnaud Lacombe 2011-07-28 01:22:25 UTC
Created attachment 24852 [details]
non-reduced testcase

command to reproduce the ICE:

% h8300-elf-gcc -O2 -mh -mint32 -g -fomit-frame-pointer -c -o elevator.o elevator.i
Comment 3 Richard Henderson 2011-07-28 16:20:58 UTC
Mine.
Comment 4 Richard Henderson 2011-07-31 15:38:17 UTC
The problem is cross-jumping at different stack heights.
Comment 5 Richard Henderson 2011-08-01 23:02:32 UTC
Fixed by the proposed patch for PR49864:
  http://gcc.gnu.org/ml/gcc-patches/2011-08/msg00075.html
Comment 6 Richard Henderson 2011-08-02 22:20:26 UTC
Fixed.