Bug 48840 - [4.5 regression] assertion failure in reload1.c
Summary: [4.5 regression] assertion failure in reload1.c
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 4.4.5
: P4 normal
Target Milestone: 4.6.1
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2011-05-01 22:01 UTC by Hans-Peter Nilsson
Modified: 2012-07-02 09:54 UTC (History)
2 users (show)

See Also:
Host:
Target: sparc64-*-*
Build:
Known to work: 4.3.5, 4.6.1
Known to fail: 4.4.5, 4.5.4
Last reconfirmed: 2011-05-01 22:02:32


Attachments
Preprocessed, trivially reduced test-case (2.19 KB, text/plain)
2011-05-01 22:01 UTC, Hans-Peter Nilsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Nilsson 2011-05-01 22:01:30 UTC
Created attachment 24159 [details]
Preprocessed, trivially reduced test-case

For gcc-4.4.0 and gcc-4.4.5, observe the following ICE for the attachment, running "cc1 -fpreprocessed ~/rcf3.i -mptr64 -mstack-bias -mlong-double-128 -mcpu=ultrasparc -m64 -mvis -O2 -funroll-loops -fPIC -o rc_filter.s":

/home/hp/rcf3.i: In function 'rc_filter_sobel_3x3_horz_u8':
/home/hp/rcf3.i:26: internal compiler error: in reload, at reload1.c:1170
where that line has a "gcc_assert (old_frame_size == get_frame_size ())".

Similarly for trunk revision 172690 (same line, different number)
though not for revision 170836 (now the 4.6 branch) and not for gcc-4.3.5.
Comment 1 Hans-Peter Nilsson 2011-05-01 23:45:57 UTC
Ouch, forgot target field...
Comment 2 Eric Botcazou 2011-06-01 20:51:57 UTC
Investigating.
Comment 3 Eric Botcazou 2011-06-02 12:58:23 UTC
Recategorizing.
Comment 4 Eric Botcazou 2011-06-02 13:04:45 UTC
Author: ebotcazou
Date: Thu Jun  2 13:04:43 2011
New Revision: 174566

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=174566
Log:
	PR rtl-optimization/48840
	* gcc.target/sparc/ultrasp13.c: New test.

Added:
    trunk/gcc/testsuite/gcc.target/sparc/ultrasp13.c
Modified:
    trunk/gcc/testsuite/ChangeLog
Comment 5 Eric Botcazou 2011-06-02 13:07:38 UTC
Works on the mainline now.
Comment 6 Eric Botcazou 2011-06-02 19:59:49 UTC
The problem is that reload chooses a FP reg as reload register for a V8QI value coming in from a general register.  So a secondary memory is needed and this increases the frame size.
Comment 7 xiaoyuanbo 2012-02-22 12:44:36 UTC
you ask
Comment 8 Jakub Jelinek 2012-03-13 12:48:24 UTC
4.4 branch is being closed, moving to 4.5.4 target.
Comment 9 Richard Biener 2012-07-02 09:54:52 UTC
Fixed for 4.6.1.