Bug 48796 - gcc: Internal error: Killed (program cc1) while compiling PHP
Summary: gcc: Internal error: Killed (program cc1) while compiling PHP
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.5.3
: P3 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-27 23:41 UTC by William Johnston
Modified: 2013-10-21 20:11 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2011-04-28 10:03:45


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Johnston 2011-04-27 23:41:56 UTC
In php-5.3.6, the file ext/fileinfo/libmagic/apprentice.c fails to compile on a Gumstix Overo running Angstrom Linux.

The compiler was cross compiled using Bitbake to the Gumstix Overo from Ubuntu.

gcc version 4.5.3 20110223 (prerelease)

Last bit of verbose output:

/usr/libexec/gcc/arm-angstrom-linux-gnueabi/4.5.3/cc1 -fpreprocessed apprentice.i -quiet -dumpbase apprentice.c -auxbase-strip apprentice.lo -g -O2 -version -fvisibility=hidden -o apprentice.s
GNU C (GCC) version 4.5.3 20110223 (prerelease) (arm-angstrom-linux-gnueabi)
	compiled by GNU C version 4.5.3 20110223 (prerelease), GMP version 5.0.1, MPFR version 3.0.0-p7, MPC version 0.8.2
GGC heuristics: --param ggc-min-expand=46 --param ggc-min-heapsize=30222
GNU C (GCC) version 4.5.3 20110223 (prerelease) (arm-angstrom-linux-gnueabi)
	compiled by GNU C version 4.5.3 20110223 (prerelease), GMP version 5.0.1, MPFR version 3.0.0-p7, MPC version 0.8.2
GGC heuristics: --param ggc-min-expand=46 --param ggc-min-heapsize=30222
Compiler executable checksum: 246c3547883d599e3b96ce1bee99ed7b
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
Comment 1 Richard Biener 2011-04-28 10:03:45 UTC
You appearantly ran out of memory and the kernel decided to kill cc1.  This
is likely not a GCC bug.  How much memory do you have?

Please attach apprentice.i.
Comment 2 William Johnston 2011-05-03 15:37:55 UTC
(In reply to comment #1)
> You appearantly ran out of memory and the kernel decided to kill cc1.  This
> is likely not a GCC bug.  How much memory do you have?

Oh, that's possible I guess. I have 256MB and no swap. I can't say how much was remaining when I was compiling the program. 

> 
> Please attach apprentice.i.

I thought I had attached the apprentice.i file... I just tried it again and it's too large. 

You can pick it up here: ftp://cast-ftp1.cast.uark.edu/wgj/apprentice.i
Comment 3 Jonathan Wakely 2011-05-03 15:46:42 UTC
That's not a lot of memory.

You could use gzip to compress the file before attaching it.
Comment 4 bryan 2012-09-24 00:32:10 UTC
(In reply to comment #1)
> You appearantly ran out of memory and the kernel decided to kill cc1.  This
> is likely not a GCC bug.  How much memory do you have?
> 
> Please attach apprentice.i.

oh,I wish I had read these comments earlier. turns out the process got killed due to using excessive memory by the host.
Comment 5 Marek Polacek 2013-10-21 20:11:06 UTC
Closing.