Bug 48567 - g++ segmentation fault on firefox build
Summary: g++ segmentation fault on firefox build
Status: RESOLVED DUPLICATE of bug 48549
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.6.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 06:24 UTC by ojab
Modified: 2011-04-12 06:28 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
preprocessed file (149.81 KB, text/plain)
2011-04-12 06:27 UTC, ojab
Details
assembler output (19.46 KB, text/plain)
2011-04-12 06:28 UTC, ojab
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ojab 2011-04-12 06:24:20 UTC
/sources/mozilla-central/js/src/methodjit/MonoIC.cpp: In member function 'void js::mjit::JITScript::sweepCallICs(JSContext*, bool)':
/sources/mozilla-central/js/src/methodjit/MonoIC.cpp:1338:1: internal compiler error: Segmentation fault

Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.1/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc-4.6/configure --prefix=/usr --libexecdir=/usr/lib --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++ --disable-multilib --enable-bootstrap --with-system-zlib --enable-plugin
Thread model: posix
gcc version 4.6.1 20110411 (prerelease) (GCC)
Comment 1 ojab 2011-04-12 06:27:40 UTC
Created attachment 23959 [details]
preprocessed file
Comment 2 ojab 2011-04-12 06:28:05 UTC
Created attachment 23960 [details]
assembler output
Comment 3 Jakub Jelinek 2011-04-12 06:28:44 UTC
Dup of PR48549.

*** This bug has been marked as a duplicate of bug 48549 ***