Bug 47824 - Option to enable all warning (-Wall-real?)
Summary: Option to enable all warning (-Wall-real?)
Status: RESOLVED DUPLICATE of bug 31573
Alias: None
Product: gcc
Classification: Unclassified
Component: other (show other bugs)
Version: unknown
: P3 enhancement
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-20 15:20 UTC by Olaf van der Spek
Modified: 2011-02-21 13:11 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf van der Spek 2011-02-20 15:20:13 UTC
Could an option be added that enables all warnings?
Comment 1 Olaf van der Spek 2011-02-20 15:33:21 UTC
It would also be nice to list all warnings not included in -Wall -Wextra.
Comment 2 Andrew Pinski 2011-02-20 20:40:57 UTC
(In reply to comment #1)
> It would also be nice to list all warnings not included in -Wall -Wextra.

The list in the manual already.
Comment 3 Andrew Pinski 2011-02-20 20:42:02 UTC
Dup of bug 31573.

*** This bug has been marked as a duplicate of bug 31573 ***
Comment 4 Olaf van der Spek 2011-02-20 21:07:07 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > It would also be nice to list all warnings not included in -Wall -Wextra.
> 
> The list in the manual already.

Where?
Comment 5 Manuel López-Ibáñez 2011-02-20 22:38:42 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > It would also be nice to list all warnings not included in -Wall -Wextra.
> > 
> > The list in the manual already.
> 
> Where?

It is implicitly in the manual as those that are not mentioned as enabled by Wall or Wextra. It would be nice to have a list of options enabled by default and another list of options never enabled by default or by other option. However, I doubt that any of the current GCC devs will ever bother to create such lists, so if you are interested, please send a documentation patch. It is a matter of reading about all warning options mentioned in http://gcc.gnu.org/onlinedocs/gcc/ and creating the lists.
Comment 6 Olaf van der Spek 2011-02-21 09:45:21 UTC
(In reply to comment #5)
> It is implicitly in the manual as those that are not mentioned as enabled by
> Wall or Wextra. 

So "The list in the manual already." is false.

> It would be nice to have a list of options enabled by default
> and another list of options never enabled by default or by other option.
> However, I doubt that any of the current GCC devs will ever bother to create
> such lists, so if you are interested, please send a documentation patch. It is
> a matter of reading about all warning options mentioned in
> http://gcc.gnu.org/onlinedocs/gcc/ and creating the lists.

I'll have a look.
However, I still think an option to really enable (almost) all warnings should be added. I don't agree with the comments in the earlier report.
Comment 7 Manuel López-Ibáñez 2011-02-21 12:30:27 UTC
(In reply to comment #6)
> 
> I'll have a look.
> However, I still think an option to really enable (almost) all warnings should
> be added. I don't agree with the comments in the earlier report.

Feel free to create a patch 

http://gcc.gnu.org/contribute.html

and submit it for review to gcc-patches. I think the general consensus among GCC devs is that such an option is not wanted, but if you still think is good, discussing it without a patch that defines exactly which options should be enabled is pointless.

There are literally thousands of bugs that GCC devs would like to see fixed (search for NEW or REOPENED bugs) and several other thousands UNCONFIRMED bugs that need to be reviewed and confirmed. Keeping this one open forever is just distracting and a waste of time and effort!

I am not going to close it again. If I have convinced you of the negative impact, please close this as DUPLICATED as Andrew did, or at least put it in WAITING. Otherwise, I guess in a few years you will have forgotten about this, and some GCC dev after stumbling into it for the nth time will close it forever.
Comment 8 Jonathan Wakely 2011-02-21 12:39:28 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > It is implicitly in the manual as those that are not mentioned as enabled by
> > Wall or Wextra. 
> 
> So "The list in the manual already." is false.

The information is in the manual, even if not as an explicit list.

I expect adding an explicit list would soon get out of date as it just increases the burden on contributors when adding new options.

> > It would be nice to have a list of options enabled by default
> > and another list of options never enabled by default or by other option.
> > However, I doubt that any of the current GCC devs will ever bother to create
> > such lists, so if you are interested, please send a documentation patch. It is
> > a matter of reading about all warning options mentioned in
> > http://gcc.gnu.org/onlinedocs/gcc/ and creating the lists.
> 
> I'll have a look.
> However, I still think an option to really enable (almost) all warnings should
> be added. I don't agree with the comments in the earlier report.

The fact you don't agree doesn't change the fact this is a duplicate of that report, marking it as such helps keep the discussion in one place. Please don't reopen this report.  If you want a new one for the documentation issue please open a new PR.
Comment 9 Olaf van der Spek 2011-02-21 12:47:24 UTC
> > So "The list in the manual already." is false.
> 
> The information is in the manual, even if not as an explicit list.

That's true, but not what was said.
 
> I expect adding an explicit list would soon get out of date as it just
> increases the burden on contributors when adding new options.

Adding options that can't be easily enabled / found doesn't seem very useful.
 
> The fact you don't agree doesn't change the fact this is a duplicate of that
> report, marking it as such helps keep the discussion in one place. Please don't
> reopen this report.  

How do I reopen the other report?

> If you want a new one for the documentation issue please
> open a new PR.

Why? Seems easier to use this one for it.
Comment 10 Jakub Jelinek 2011-02-21 12:55:51 UTC
Dup.

*** This bug has been marked as a duplicate of bug 31573 ***
Comment 11 Olaf van der Spek 2011-02-21 13:11:04 UTC
> Dup.

No kidding?