Bug 47406 - gcc.dg/torture/builtin-modf-1.c FAILs on IRIX 6.5
gcc.dg/torture/builtin-modf-1.c FAILs on IRIX 6.5
Status: RESOLVED WONTFIX
Product: gcc
Classification: Unclassified
Component: middle-end
4.6.0
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
:
Depends on: 48341
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-21 17:43 UTC by Rainer Orth
Modified: 2014-06-13 11:45 UTC (History)
1 user (show)

See Also:
Host: mips-sgi-irix6.5
Target: mips-sgi-irix6.5
Build: mips-sgi-irix6.5
Known to work:
Known to fail:
Last reconfirmed: 2011-07-01 16:06:51


Attachments
preprocessed input (3.98 KB, application/x-bzip2)
2011-01-21 17:44 UTC, Rainer Orth
Details
assembler output (9.33 KB, application/x-bzip2)
2011-01-21 17:45 UTC, Rainer Orth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Orth 2011-01-21 17:43:56 UTC
gcc.dg/torture/builtin-modf-1.c FAILs on IRIX 6.5 at all optimization levels:

FAIL: gcc.dg/torture/builtin-modf-1.c  -O0  (test for excess errors)
Excess errors:
ld32: ERROR   33 : Unresolved data symbol "link_error" -- 1st referenced by /var/tmp//ccw6kU6D.o.
	Use linker option -v to see when and which objects, archives and dsos are loaded.  
ld32: INFO    152: Output file removed because of error.

I'm including the -save-temps output (i.e. .i and .s files).
Comment 1 Rainer Orth 2011-01-21 17:44:45 UTC
Created attachment 23069 [details]
preprocessed input
Comment 2 Rainer Orth 2011-01-21 17:45:22 UTC
Created attachment 23070 [details]
assembler output
Comment 3 Rainer Orth 2011-07-01 16:06:51 UTC
I've just found that if I remove the long double part of TESTIT_MODF, the test
passes.  So this may well be related to PR c/48341.
Comment 4 Richard Biener 2012-03-22 08:27:31 UTC
GCC 4.7.0 is being released, adjusting target milestone.
Comment 5 Rainer Orth 2014-06-13 11:45:55 UTC
4.7 branch closed.