Bug 47405 - gcc.dg/torture/20090618-1.c FAILs on IRIX 6.5
Summary: gcc.dg/torture/20090618-1.c FAILs on IRIX 6.5
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-21 17:36 UTC by Rainer Orth
Modified: 2014-06-13 11:46 UTC (History)
1 user (show)

See Also:
Host: mips-sgi-irix6.5
Target: mips-sgi-irix6.5
Build: mips-sgi-irix6.5
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Orth 2011-01-21 17:36:00 UTC
gcc.dg/torture/20090618-1.c FAILs on IRIX 6.5 at -O1 and up:

FAIL: gcc.dg/torture/20090618-1.c  -O1  (test for excess errors)
Excess errors:
ld32: ERROR   33 : Unresolved data symbol "mempcpy" -- 1st referenced by /var/tmp//ccfiGZ5r.o.
	Use linker option -v to see when and which objects, archives and dsos are loaded.  
ld32: INFO    152: Output file removed because of error.

WARNING: gcc.dg/torture/20090618-1.c  -O1  compilation failed to produce executable
Comment 1 Rainer Orth 2011-03-17 16:56:13 UTC
Richard, this patch of yours fails on IRIX 5 and 6.  I suppose this is a target
bug, since it does pass on other platforms (Tru64 UNIX, Solaris 2/SPARC and
x86) that don't have mempcpy in libc either.

What to do about this?  XFAIL (or rather skip since otherwise the `failed to
produce executable' warnings remain)?

  Rainer
Comment 2 rguenther@suse.de 2011-03-17 16:59:13 UTC
On Thu, 17 Mar 2011, ro at gcc dot gnu.org wrote:

> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=47405
> 
> --- Comment #1 from Rainer Orth <ro at gcc dot gnu.org> 2011-03-17 16:56:13 UTC ---
> Richard, this patch of yours fails on IRIX 5 and 6.  I suppose this is a target
> bug, since it does pass on other platforms (Tru64 UNIX, Solaris 2/SPARC and
> x86) that don't have mempcpy in libc either.
> 
> What to do about this?  XFAIL (or rather skip since otherwise the `failed to
> produce executable' warnings remain)?

skip it.

Richard.
Comment 3 Rainer Orth 2011-03-18 14:10:41 UTC
Author: ro
Date: Fri Mar 18 14:10:35 2011
New Revision: 171140

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=171140
Log:
	PR middle-end/47405
	* gcc.dg/torture/20090618-1.c: Skip on mips-sgi-irix*.

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/torture/20090618-1.c
Comment 4 Rainer Orth 2011-03-18 14:13:37 UTC
Author: ro
Date: Fri Mar 18 14:13:32 2011
New Revision: 171141

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=171141
Log:
	PR middle-end/47405
	* gcc.dg/torture/20090618-1.c: Skip on mips-sgi-irix*.

Modified:
    branches/gcc-4_6-branch/gcc/testsuite/ChangeLog
    branches/gcc-4_6-branch/gcc/testsuite/gcc.dg/torture/20090618-1.c
Comment 5 Rainer Orth 2011-03-18 14:18:04 UTC
Author: ro
Date: Fri Mar 18 14:17:58 2011
New Revision: 171142

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=171142
Log:
	PR middle-end/47405
	* gcc.dg/torture/20090618-1.c: Skip on mips-sgi-irix*.

Modified:
    branches/gcc-4_5-branch/gcc/testsuite/ChangeLog
    branches/gcc-4_5-branch/gcc/testsuite/gcc.dg/torture/20090618-1.c
Comment 6 Rainer Orth 2014-06-13 11:46:35 UTC
4.7 branch closed.