User account creation filtered due to spam.

Bug 46692 - Missing LM32 multilibs for divider and sign extender
Summary: Missing LM32 multilibs for divider and sign extender
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.5.1
: P3 major
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-28 13:19 UTC by Sebastien Bourdeauducq
Modified: 2011-02-02 18:15 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Fixes the problem (222 bytes, patch)
2010-11-28 13:19 UTC, Sebastien Bourdeauducq
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien Bourdeauducq 2010-11-28 13:19:31 UTC
Created attachment 22553 [details]
Fixes the problem

Multilibs with the optional divider and the sign extender are missing for the LM32 target. Patch attached.
Comment 1 Ralf Corsepius 2010-11-28 14:27:13 UTC
Would you mind to explain, why you need this, rsp. why the current default multilibs do not suffice your needs?

Adding a multilibs to the default set of multilibs needs of a target needs to be very well motivated and can not be done light-heartedly.

Knowing you actually are working with lm32-rtems and not with lm32-* targets, provided you can sufficiently motivate this change, raises the question if it would not actally be more appropriate to extend the lm32-rtems multilib set instead of the general set of multilibs.
Comment 2 Sebastien Bourdeauducq 2010-11-30 23:29:18 UTC
(In reply to comment #1)
I'm sorry, but are you really trying to argue that libraries like libc and libm MUST ALWAYS use the software emulation of the divider and sign extender (even if their hardware versions are available on the CPU), as not applying this change would imply?

The reason is simple, if you haven't guessed it: speed (and code size, but this matters less). Not for me only, but for everyone else as well.
Comment 3 Sebastien Bourdeauducq 2011-02-01 11:52:15 UTC
Author: lekernel
Date: Tue Feb  1 11:52:12 2011
New Revision: 169473

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=169473
Log:
	PR gcc/46692
	* config/lm32/t-lm32: Add multilib for all CPU options.


Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/lm32/t-lm32
Comment 4 Sebastien Bourdeauducq 2011-02-01 12:01:12 UTC
see comment #3
Comment 5 Diego Novillo 2011-02-02 18:15:08 UTC
Author: dnovillo
Date: Wed Feb  2 18:15:02 2011
New Revision: 169743

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=169743
Log:
	PR gcc/46692
	* config/lm32/t-lm32: Add multilib for all CPU options.

Modified:
    branches/google/integration/gcc/ChangeLog
    branches/google/integration/gcc/config/lm32/t-lm32