Bug 46506 - GCC miscompiled 465.tonto in SPEC CPU 2006
Summary: GCC miscompiled 465.tonto in SPEC CPU 2006
Status: RESOLVED DUPLICATE of bug 46842
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: 4.6.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-16 17:44 UTC by H.J. Lu
Modified: 2010-12-09 04:07 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2010-12-09 04:06:16


Attachments
The src.alt for 465.tonto (11.16 KB, application/octet-stream)
2010-11-17 13:19 UTC, H.J. Lu
Details
Miscompare of stdout (456 bytes, text/plain)
2010-11-20 20:07 UTC, H.J. Lu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2010-11-16 17:44:04 UTC
On Linux/x86-64, revision 166795 with  -O3 -funroll-loops -ffast-math -fwhole-program -flto=jobserver -ffixed-form gave

  Running 465.tonto test peak lto default

*** Miscompare of stdout; for details see
    /export/gnu/import/svn/gcc-test-spec/spec/2006/x86_64/spec/benchspec/CPU2006
/465.tonto/run/run_peak_test_lto.0000/stdout.mis
Comment 1 Richard Biener 2010-11-17 11:51:23 UTC
Hm, worked for me last time.  Re-checking with r166798.
Comment 2 Richard Biener 2010-11-17 12:05:24 UTC
Tonto works for me.
Comment 3 H.J. Lu 2010-11-17 13:19:07 UTC
Created attachment 22429 [details]
The src.alt for 465.tonto

Can you try this alternate source for tonto with

-O3 -funroll-loops -ffast-math -fwhole-program -flto=jobserver -fuse-linker-plugin
Comment 4 Richard Biener 2010-11-17 13:36:03 UTC
I have different alternate source, calling destroy_ptr_part_ instead.

But I can't parse the perl patch, so I'm not 100% sure.
Comment 5 H.J. Lu 2010-11-18 01:52:20 UTC
As of revision 166870, tonto failed with test input, "-i test",
and passed with normal input.
Comment 6 H.J. Lu 2010-11-20 20:05:51 UTC
Tonto also failed without LTO on test input:

  Running 465.tonto test base lnx32e-gcc default

*** Miscompare of stdout; for details see
    /export/gnu/import/svn/gcc-test-spec/spec/2006/x86_64/spec/benchspec/CPU2006/465.tonto/run/run_base_test_lnx32e-gcc.0000/stdout.mis
Comment 7 H.J. Lu 2010-11-20 20:07:08 UTC
Created attachment 22471 [details]
Miscompare of stdout
Comment 8 Changpeng Fang 2010-12-08 00:50:31 UTC
*** Bug 46842 has been marked as a duplicate of this bug. ***
Comment 9 Changpeng Fang 2010-12-08 00:54:08 UTC
This is not a optimization bug because it fails with -O0.
I am seeking a working src_alt. Thanks.
Comment 10 H.J. Lu 2010-12-08 01:09:37 UTC
Tonto always fails with test input. Ignore it.
Comment 11 H.J. Lu 2010-12-09 04:06:16 UTC
It is a real bug.
Comment 12 H.J. Lu 2010-12-09 04:07:04 UTC
Dup.

*** This bug has been marked as a duplicate of bug 46842 ***