Bug 46475 - [4.6 Regression] FAIL: gcc.dg/nofixed-point-2.c
Summary: [4.6 Regression] FAIL: gcc.dg/nofixed-point-2.c
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: 4.6.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-14 15:32 UTC by H.J. Lu
Modified: 2010-11-14 15:47 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2010-11-14 15:32:12 UTC
On Linux/ia32, revision 166732 gave

FAIL: gcc.dg/nofixed-point-2.c  (test for warnings, line 12)

Revision 166728 is OK.
Comment 1 H.J. Lu 2010-11-14 15:34:11 UTC
It may be caused by revision 166732:

http://gcc.gnu.org/ml/gcc-cvs/2010-11/msg00621.html
Comment 2 Paolo Bonzini 2010-11-14 15:47:03 UTC
Author: bonzini
Date: Sun Nov 14 15:46:59 2010
New Revision: 166733

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=166733
Log:
2010-11-14  Paolo Bonzini  <bonzini@gnu.org>

	PR c/46475
	* gcc.dg/nofixed-point-2.c: Change dg-warning to dg-bogus.


Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/nofixed-point-2.c
Comment 3 Paolo Bonzini 2010-11-14 15:47:12 UTC
I think I have to debug my test scripts.  I'm committing the change from dg-warning to dg-bogus.
Comment 4 Paolo Bonzini 2010-11-14 15:47:48 UTC
fixed.