Bug 45654 - -fwhole-file doesn't warn about INTERFACE vs. definition mismatches
Summary: -fwhole-file doesn't warn about INTERFACE vs. definition mismatches
Status: RESOLVED DUPLICATE of bug 27318
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks: 29670
  Show dependency treegraph
 
Reported: 2010-09-13 12:15 UTC by Jakub Jelinek
Modified: 2010-12-28 18:23 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2010-09-22 05:31:30


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Jelinek 2010-09-13 12:15:03 UTC
Sorry if this is a dup.
Is there any reason why with -fwhole-file we don't warn about:
subroutine foo(ptr, ptr2, f)
  integer, pointer :: ptr(:), ptr2(:)
  logical :: f
  if (f) then
    allocate (ptr(6))
  else
    nullify(ptr)
  end if
end subroutine
subroutine bar()
  real, pointer :: ptr(:), ptr2(:)
  real, target :: a(6)
  interface
    subroutine foo(ptr, ptr2, f)
      real, pointer :: ptr(:), ptr2(:)
      logical :: f
    end subroutine
  end interface
  ptr2 = a
  call foo(ptr, ptr2, .true.)
  ptr = a + 6
end subroutine

?
Comment 1 Paul Thomas 2010-09-22 05:31:30 UTC
No.

Confirmed - thanks for picking it up.

Paul
Comment 2 Daniel Franke 2010-12-28 18:23:33 UTC
Same as #27318.

*** This bug has been marked as a duplicate of bug 27318 ***