Bug 45494 - [OOP] Wrong dummy argument not rejected
Summary: [OOP] Wrong dummy argument not rejected
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: accepts-invalid
Depends on:
Blocks:
 
Reported: 2010-09-02 10:15 UTC by Salvatore Filippone
Modified: 2010-10-28 15:26 UTC (History)
3 users (show)

See Also:
Host: x86_64-unknown-linux-gnu
Target: x86_64-unknown-linux-gnu
Build: x86_64-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2010-09-02 12:55:02


Attachments
test-case (307 bytes, text/plain)
2010-09-02 10:16 UTC, Salvatore Filippone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Salvatore Filippone 2010-09-02 10:15:56 UTC
Hello,
The attached code is rejected by XLF 13.1 and NAG, but is accepted by gfortran. 
The problem is that the second instance of the call to the MOLD method passes an object that is not type compatible.
==========================gfortran=====================
[sfilippo@localhost bug24]$ gfortran -v 
Using built-in specs.
COLLECT_GCC=gfortran
COLLECT_LTO_WRAPPER=/usr/local/gnu46/libexec/gcc/x86_64-unknown-linux-gnu/4.6.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc/configure --prefix=/usr/local/gnu46 --enable-languages=c,c++,fortran : (reconfigured) ../gcc/configure --prefix=/usr/local/gnu46 --enable-languages=c,c++,fortran
Thread model: posix
gcc version 4.6.0 20100902 (experimental) (GCC) 
[sfilippo@localhost bug24]$ gfortran -c bug24.f03 
[sfilippo@localhost bug24]$ 
==================== xlf ===================================
bash-3.2$ which xlf
/opt/IBM/compilers/xlf13.1/usr/bin/xlf
bash-3.2$ xlf2003 -c bug24.f03 
** foo_mod   === End of Compilation 1 ===
** foo_2_mod   === End of Compilation 2 ===
** foo_3_mod   === End of Compilation 3 ===
"bug24.f03", line 43.17: 1513-061 (S) Actual argument attributes do not match those specified by an accessible explicit interface.
** bar   === End of Compilation 4 ===
1501-511  Compilation failed for file bug24.f03.
Comment 1 Salvatore Filippone 2010-09-02 10:16:35 UTC
Created attachment 21653 [details]
test-case
Comment 2 janus 2010-09-02 12:55:02 UTC
Confirmed.
Comment 3 Dominique d'Humieres 2010-10-28 09:36:02 UTC
This pr seems to be fixed by revision 166018:

[macbook] f90/bug% gfc pr45494.f90
pr45494.f90:43.16:

  call src%mold(trg2)  ! This is wrong
                1
Error: Actual argument to 'b' at (1) must have the same declared type
Comment 4 Tobias Burnus 2010-10-28 12:11:35 UTC
(In reply to comment #3)
> This pr seems to be fixed by revision 166018:

Looking at the test case and the description, I think that's fixed by the patch for PR 46161; cf. http://gcc.gnu.org/ml/fortran/2010-10/msg00259.html

Thus, I close this PR as fixed. Thanks for Salvatore for the bug report.
Comment 5 janus 2010-10-28 15:26:25 UTC
(In reply to comment #4)
> Looking at the test case and the description, I think that's fixed by the patch
> for PR 46161; cf. http://gcc.gnu.org/ml/fortran/2010-10/msg00259.html
> 
> Thus, I close this PR as fixed. Thanks for Salvatore for the bug report.

Yes. Closing.