Bug 44926 - [OOP] Ambiguous interface not detected
Summary: [OOP] Ambiguous interface not detected
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: ---
Assignee: janus
URL:
Keywords: accepts-invalid
Depends on:
Blocks:
 
Reported: 2010-07-13 08:30 UTC by Tobias Burnus
Modified: 2010-10-30 13:56 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2010-07-13 08:30:58 UTC
Follow up to PR 44434.

Test case: attachment 20850 [details]


While gfortran compiles the program, both ifort and crayftn reject it with:

aaa.f90(98): error #8443: This generic type bound procedure reference has two or more specific procedures with the same type/rank/keyword signature.   [CSGET]
    call a%a%csget(ires,info)


ftn-487 crayftn: ERROR D_BASE_MAT_MOD, File = aaa.f90, Line = 33, Column = 37
  The specific interfaces for "D_XXX_GET" and "BASE_CSGETP" make the GENERIC interface "CSGET" ambiguous.
Comment 1 Tobias Burnus 2010-07-13 08:59:54 UTC
Is probably a duplicate of PR 44917
Comment 2 janus 2010-10-30 13:52:44 UTC
Author: janus
Date: Sat Oct 30 13:52:39 2010
New Revision: 166089

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=166089
Log:
2010-10-30  Janus Weil  <janus@gcc.gnu.org>

	PR fortran/44917
	PR fortran/44926
	PR fortran/46196
	* interface.c (count_types_test): Symmetrize type check.
	(generic_correspondence): Ditto.

2010-10-30  Janus Weil  <janus@gcc.gnu.org>

	PR fortran/44917
	PR fortran/44926
	PR fortran/46196
	* gfortran.dg/typebound_generic_10.f03: New.

Added:
    trunk/gcc/testsuite/gfortran.dg/typebound_generic_10.f03
Modified:
    trunk/gcc/fortran/ChangeLog
    trunk/gcc/fortran/interface.c
    trunk/gcc/testsuite/ChangeLog
Comment 3 janus 2010-10-30 13:56:04 UTC
Fixed with r166089. Closing.