Bug 44787 - [4.6 Regression] internal compiler error: in reload_cse_simplify_operands, at postreload.c:395
Summary: [4.6 Regression] internal compiler error: in reload_cse_simplify_operands, at...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: 4.6.0
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
: 44788 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-02 17:38 UTC by Jing Yu
Modified: 2010-07-06 23:46 UTC (History)
3 users (show)

See Also:
Host: x86_64-pc-linux-gnu
Target: arm-linux-androideabi,arm-eabi
Build: x86_64-pc-linux-gnu
Known to work:
Known to fail: 4.6.0
Last reconfirmed: 2010-07-03 00:01:58


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jing Yu 2010-07-02 17:38:29 UTC
Revision 160947 breaks the following test case.

void joint_decode(float* mlt_buffer1, int t) {
    int i;
    float decode_buffer[1060];
    foo(decode_buffer);
    for (i=0; i<10 ; i++) {
        mlt_buffer1[i] = i * decode_buffer[t];
    }
}

/usr/local/install/R160947/libexec/gcc/arm-linux-androideabi/4.6.0/cc1 -fpreprocessed cook.i -fPIC -quiet -dumpbase cook.i  "-march=armv7-a" "-mfloat-abi=softfp" "-mfpu=neon" -mthumb -auxbase-strip cook.o -Os   -fno-strict-aliasing  -o /tmp/ccrdKipa.s 

cook.i: In function 'joint_decode':
cook.i:8:1: error: insn does not satisfy its constraints:
(insn 98 55 59 2 cook.i:6 (set (reg:SI 3 r3)
        (plus:SI (mult:SI (reg/v:SI 5 r5 [orig:183 t ] [183])
                (const_int 4 [0x4]))
            (reg/f:SI 13 sp))) 674 {*thumb2_arith_shiftsi} (nil))
cook.i:8:1: internal compiler error: in reload_cse_simplify_operands, at postreload.c:395
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

I tried revision 160946 and did not see such error. The bug may not be brought by r160947, but it was triggered.
Comment 1 Richard Earnshaw 2010-07-02 21:06:58 UTC
*** Bug 44788 has been marked as a duplicate of this bug. ***
Comment 2 Ramana Radhakrishnan 2010-07-03 00:01:58 UTC
I haven't verified the actual revision failing but I do see this failing as of trunk today with an eabi compiler and all the options specified.
Comment 3 Bernd Schmidt 2010-07-06 23:45:13 UTC
Subject: Bug 44787

Author: bernds
Date: Tue Jul  6 23:44:55 2010
New Revision: 161893

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=161893
Log:
	PR rtl-optimization/44787
	* config/arm/arm.md (arith_shiftsi): Allow stack pointer in operand 2.
	* config/arm/thumb2.md (thumb2_arith_shiftsi): Likewise.

testsuite/
	PR rtl-optimization/44787
	* gcc.c-torture/compile/pr44788.c: New test.
	* gcc.target/arm/pr44788.c: New test.


Added:
    trunk/gcc/testsuite/gcc.c-torture/compile/pr44788.c
    trunk/gcc/testsuite/gcc.target/arm/pr44788.c
Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/arm/arm.md
    trunk/gcc/config/arm/thumb2.md
    trunk/gcc/testsuite/ChangeLog

Comment 4 Bernd Schmidt 2010-07-06 23:46:24 UTC
Fixed.