Bug 44433 - [meta-bug] --enable-build-with-cxx issues
Summary: [meta-bug] --enable-build-with-cxx issues
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.6.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: meta-bug
Depends on: 52928 42843 44362 44431 44432 44459 44512 44637 44640 44670 44751 44755 44758 44832 45050 45444 46412 46415 46435 46438 46450 46574 46881 48899 53635
Blocks: 44566
  Show dependency treegraph
 
Reported: 2010-06-06 11:55 UTC by Richard Biener
Modified: 2013-02-26 10:24 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Biener 2010-06-06 11:55:23 UTC
Issues to be fixed before --enable-build-with-cxx can be made the default.
Comment 1 Jorn Wolfgang Rennecke 2010-06-08 23:15:32 UTC
I think PR44362 no longer block adoption of --enable-build-with-cxx
in trunk, since the C++ part of the patch for that PR was checked in.
It might sense to keep it in the dependency list if we need this to
backport the fixes into a branch, though.
Comment 2 Jorn Wolfgang Rennecke 2010-06-23 08:58:19 UTC
Should I add PR44644 to the list of PRs blocking this one?  Although you
can bootstrap gcc without fixing that PR, it causes considerable problems
when debugging gcc, and it could be easily fixed.
Comment 3 Doug Semler 2010-07-11 15:11:06 UTC
Does anyone know if pr43538 affects this as well (cxx flags fir target inheriting from cxxflags on Linux targets)?
Comment 4 Richard Biener 2013-02-26 10:24:14 UTC
Fixed.  --enable-build-with-cxx is gone (always on).