User account creation filtered due to spam.

Bug 43055 - [5/6/7 Regression] 'jc1: internal compiler error: Segmentation fault' using gcj -fprofile-arcs
Summary: [5/6/7 Regression] 'jc1: internal compiler error: Segmentation fault' using...
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.4.1
: P5 normal
Target Milestone: 5.5
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2010-02-12 18:09 UTC by Elden Crom
Modified: 2016-10-03 05:44 UTC (History)
2 users (show)

See Also:
Host: i486-linux-gnu
Target: i486-linux-gnu
Build: i486-linux-gnu
Known to work: 4.2.4
Known to fail: 4.3.4, 4.4.1, 4.5.0
Last reconfirmed: 2010-02-13 10:32:05


Attachments
compiling this helloworld with 'gcj -fprofile-arcs -g --main=test test.java' seg faults (101 bytes, text/plain)
2010-02-12 18:17 UTC, Elden Crom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elden Crom 2010-02-12 18:09:31 UTC
Appear to be a recurrence of an older 'fixed' bug
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=8260
I will attempt to compile the latest version gcj and see if the problem exists there as well.
================ test.java ================
public class test {
  public static void main(String[] args) {
    System.out.println("Hi Elden");
  }
}
============================================
gcj -fprofile-arcs -g --main=test test.java



eldenlinux2: /e/junk $ gcj -v
Using built-in specs.
Reading specs from /usr/lib/gcc/i486-linux-gnu/4.4.1/libgcj.spec
rename spec startfile to startfileorig
rename spec lib to liborig
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.4.1-5ubuntu2' --with-bugurl=file:///usr/share/doc/gcj-4.4/README.Bugs --enable-languages=c,c++,java --prefix=/usr --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4 --enable-nls --enable-clocale=gnu --disable-libmudflap --enable-java-awt=gtk --enable-gtk-cairo --disable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.4/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.4 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.4 --with-arch-directory=i386 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-targets=all --disable-werror --with-arch-32=i486 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.1 (Ubuntu 4.4.1-5ubuntu2)
Comment 1 Elden Crom 2010-02-12 18:17:19 UTC
Created attachment 19851 [details]
compiling this helloworld with 'gcj -fprofile-arcs -g --main=test test.java' seg faults
Comment 2 Richard Biener 2010-02-13 10:32:05 UTC
Also fails for me with 4.3 and trunk.
Comment 3 Richard Biener 2010-02-13 10:35:23 UTC
Program received signal SIGSEGV, Segmentation fault.
0x08158cf6 in coverage_checksum_string (chksum=0, string=0x0)
    at /home/richard/src/trunk/gcc/coverage.c:484
484	  for (i = 0; string[i]; i++)

Looks like the current function does not have a location.

536	{
537	  expanded_location xloc
538	    = expand_location (DECL_SOURCE_LOCATION (current_function_decl));
539	  unsigned chksum = xloc.line;
540	
541	  chksum = coverage_checksum_string (chksum, xloc.file);
542	  chksum = coverage_checksum_string
543	    (chksum, IDENTIFIER_POINTER (DECL_ASSEMBLER_NAME (current_function_decl)));
544	
545	  return chksum;
(gdb) p xloc
$3 = {file = 0x0, line = 0, column = 0, sysp = 0 '\000'}
(gdb) call debug_generic_expr (current_function_decl)
_Jv_global_static_constructor

Comment 4 Richard Biener 2010-05-22 18:13:51 UTC
GCC 4.3.5 is being released, adjusting target milestone.
Comment 5 Richard Biener 2011-06-27 12:14:10 UTC
4.3 branch is being closed, moving to 4.4.7 target.
Comment 6 Jakub Jelinek 2012-03-13 12:47:27 UTC
4.4 branch is being closed, moving to 4.5.4 target.
Comment 7 Jakub Jelinek 2013-04-12 15:16:50 UTC
GCC 4.6.4 has been released and the branch has been closed.
Comment 8 Richard Biener 2014-06-12 13:45:50 UTC
The 4.7 branch is being closed, moving target milestone to 4.8.4.
Comment 9 Jakub Jelinek 2014-12-19 13:35:42 UTC
GCC 4.8.4 has been released.
Comment 10 Richard Biener 2015-06-23 08:18:14 UTC
The gcc-4_8-branch is being closed, re-targeting regressions to 4.9.3.
Comment 11 Jakub Jelinek 2015-06-26 19:59:09 UTC
GCC 4.9.3 has been released.
Comment 12 Richard Biener 2016-08-03 10:46:46 UTC
GCC 4.9 branch is being closed
Comment 13 Andrew Pinski 2016-10-03 05:44:12 UTC
Won't be fixed as it has been a bug for the last 6 years and now GCJ has been removed.