Bug 42849 - 4.4.3 build failure: jar: internal error:
4.4.3 build failure: jar: internal error:
Status: RESOLVED DUPLICATE of bug 39177
Product: gcc
Classification: Unclassified
Component: java
4.4.3
: P3 critical
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-22 18:55 UTC by ronis
Modified: 2010-01-22 22:10 UTC (History)
10 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ronis 2010-01-22 18:55:09 UTC
I'm trying a bootstrap build of 4.4.3 on a i686-Slackware-12.2 box.   I successfully built on a similar box.  I'm using default CFLAGS and configure with:

--host=i686-pc-linux-gnu --prefix=/usr --with-gnu-as --enable-shared --with-gnu-ld --enable-threads=posix --with-ecj-jar=/usr/share/java/ecj.jar --enable-languages=c,c++,fortran,java,objc

The build dies with:

libtool: compile:  /home/ronis/objdir/./gcc/xgcc -shared-libgcc -B/home/ronis/objdir/./gcc -nostdinc++ -L/home/ronis/objdir/i6
86-pc-linux-gnu/libstdc++-v3/src -L/home/ronis/objdir/i686-pc-linux-gnu/libstdc++-v3/src/.libs -B/usr/i686-pc-linux-gnu/bin/ -
B/usr/i686-pc-linux-gnu/lib/ -isystem /usr/i686-pc-linux-gnu/include -isystem /usr/i686-pc-linux-gnu/sys-include -DHAVE_CONFIG
_H -I. -I../../../gcc/libjava -I./include -I./gcj -I../../../gcc/libjava -Iinclude -I../../../gcc/libjava/include -I../../../g
cc/libjava/classpath/include -Iclasspath/include -I../../../gcc/libjava/classpath/native/fdlibm -I../../../gcc/libjava/../boeh
m-gc/include -I../boehm-gc/include -I../../../gcc/libjava/libltdl -I../../../gcc/libjava/libltdl -I../../../gcc/libjava/.././l
ibjava/../gcc -I../../../gcc/libjava/../zlib -I../../../gcc/libjava/../libffi/include -I../libffi/include -fno-rtti -fnon-call
-exceptions -fdollars-in-identifiers -Wswitch-enum -D_FILE_OFFSET_BITS=64 -ffloat-store -fomit-frame-pointer -Usun -Wextra -Wa
ll -D_GNU_SOURCE -DPREFIX=\"/usr\" -DTOOLEXECLIBDIR=\"/usr/lib\" -DJAVA_HOME=\"/usr\" -DBOOT_CLASS_PATH=\"/usr/share/java/libg
cj-4.4.3.jar\" -DJAVA_EXT_DIRS=\"/usr/share/java/ext\" -DGCJ_ENDOR
SED_DIRS=\"/usr/share/java/gcj-endorsed\" -DGCJ_VERSIONED_LIBDIR=\"/usr/lib/gcj-4.4.3-10\" -DPATH_SEPARATOR=\":\" -DECJ_JAR_FILE=\"/usr/share/java/ecj.jar\" -DLIBGCJ_DEFAULT_DATABASE=\"/usr/lib/gcj-4.4.3-10/classmap.db\" -DLIBGCJ_DEFAULT_DATABASE_PATH_TAIL=\"gcj-4.4.3-10/classmap.db\" -g -O2 -D_GNU_SOURCE -MT posix-threads.lo -MD -MP -MF .deps/posix-threads.Tpo -c ../../../gcc/libjava/posix-threads.cc -o posix-threads.o >/dev/null 2>&1
here=`pwd`; cd ../../../gcc/libjava/classpath/lib; \
        find gnu java javax org sun -name .svn -prune -o -name '*.class' -print | \
        gjar -cfM@ $here/libgcj-4.4.3.jar
jar: internal error:
java.lang.NullPointerException
   at gnu.classpath.tools.jar.Creator.writeCommandLineEntries(libgcj-tools.so.10)
   at gnu.classpath.tools.jar.Creator.run(libgcj-tools.so.10)
   at gnu.classpath.tools.jar.Main.run(libgcj-tools.so.10)
   at gnu.classpath.tools.jar.Main.main(libgcj-tools.so.10)
make[3]: *** [libgcj-4.4.3.jar] Error 1

gjar --version

gives 

jar (GNU Classpath) 0.98.  Any chance this is related to bug 41472?
Comment 1 Richard Biener 2010-01-22 22:10:26 UTC
You need to fix your host gjar tool.

*** This bug has been marked as a duplicate of 39177 ***